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Chapter I. Geolocation
1. DEFINITION
The VISUAL PLANNING GEOLOCATION module enables you to:
■ Calculate and visualize the geographical position of a resource,
■ Visualize possible routings,
■ Calculate the distances of these routings, particularly when assigning resources to an event.
This module therefore provides a new criterion for help with planning: calculation of distances.
For example it is now possible to find the people closest to the work location.

2. PREREQUISITES
Technical prerequisites
Some of these functionalities require Internet access:
■ Calculation of GPS coordinates,
■ View of positions,
■ View of routings,
■ Calculation of distances.
The GEOLOCATION module can be used with Google Maps or HereWeGo.
In order to use either of those properties, you must obtain an API key.
For each provider, please refer to the following links to learn more about maximum number
of requests and plans limits:
■ Google Maps: https://cloud.google.com/maps-platform/pricing/sheet/;
■ Here We Go: https://developer.here.com/plans.

Functional pre-requisites
The GEOLOCATION module requires:
■ The presence of at least two Geolocation type headings in one or more dimensions,
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■ and possibly the presence of at least one Distance type heading in a form.

Creating a key for Google Maps
In order to use the Google Maps API you must create a “key”. To do that, you must have a Google
account.
Once you have a Google account,
console.developers.google.com/home

log

into

the

following

address:

https://

Now type in your IDs, then click on Select a project to display the following window.

Create a new project by clicking on this button
. Now enter the name of your project in the window
that displays. Click on Create to create the project.
To go to your new project click on the link that is displayed in the previous project selection window.

STILOG IST, all rights reserved

2

Modules

Once you have chosen your project, create an API key by clicking on "Access the API preview":

Click on IDs to create an ID. This identifier is mandatory in order to access the APIs.
Now click on Create IDs> API key.
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Copy the key and paste it for the next steps.

Once they key is generated, go back to the "Dashboard" or "Library” menu to enable the following
APIs:
■ Google Maps JavaScript API,
■ Google Maps Geocoding API,
■ Google Maps Distance Matrix API,
■ Google Maps Directions API.
To do this go to the following interface:

STILOG IST, all rights reserved

4

Modules

Find the APIs above, click on each API and enable it:

Creating a key for HereWeGo
In order to use the HereWeGo API you must create a “key”. To do that, you must have a HereWeGo
account. To create an account, go to the following page: https://developer.here.com/.
Click on the Get Started for Free button.
The following window will show. Fill in the form to register a new account.
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Once your account is created, click on the menu located in the top right corner, next to your username.
The following window will show:

Click on Projects to display the next window. Click on Select a plan for a new project.
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Click on the Sign Up button for the FREMIUM plan.

Follow the instructions displayed. Once you reach the window below, click on the Generate App ID
and App Code button from the JavaScript/REST menu to generate the API keys.
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Two keys are generated: an App ID and an App Code.

Copy both keys and keep them at hand for next steps.
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3. CONFIGURATION
Prerequisites
Only users identified as “Administrators” have access to the configuration of Geolocation.
To define a user as an administrator of the Geolocation module you must log into the Admin Center.
Then in the “Modules” category, right-click > Modify on the GEOLOC module.
In the window that is displayed, click on “Administrators” to select the administrators in the left-hand
column and use the arrows to move them to the right-hand column.
Now click OK to confirm.

Configuration
Once you have obtained the Google Maps or HereWeGo key, you must register it in the settings for
the Geolocation module to enable it.
Log into the Admin Center as an administrator.
Then in the “Modules” category, right-click > Modify on the GEOLOC module.
In the window that is displayed click on [...] in the “Settings” field to show and edit the module’s settings.
Select either GoogleMapsService or HereWeGoService in the PROVIDER field, depending on the
one you plan to use.
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Paste or type in the key obtained above in the PROVIDERINFO field.
■ For Google Maps: paste the API key obtained;
■ For HereWeGo: paste both keys separated by a semicolon, without spaces, in the following order:
App ID;App Code.

Close all the windows by clicking on “OK” and “Validate”.
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4. USE
View location
For each dimension that has at least one Geolocation type of heading, a new Geolocation menu item
is displayed in the pop-up menu:
■ of its resources,
■ and of events that have at least one such geolocalized resource.

After selecting the heading a new window is displayed:
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This window enables you to view the location of the selected resource or event.
If several resources or events are selected, several locations appear on the same map.

View routing
For each dimension that has at least two Geolocation headings, a new View routing menu item is
displayed in the pop-up menu for its resources.
Similarly, for each event that has at least two geolocalized resources, this same View routing menu
item is displayed in the event’s pop-up menu.
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After selecting the routing, a new window is displayed:

This window enables you to view the routing between the two selected points.
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Assignment
The Geolocation module provides a distance calculation that gives you two new criteria to assist with
assignment:
■ Calculation of distances,
■ Localization period.
See Assignment according to distance

Calculate the distance
You can calculate the distance between 2 headings defined when configuring the Distance type
heading.
To do so, right-click on the event > Geolocation > Calculate remotely > Choose the required
Distance heading.
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The following window opens during calculation if calculation takes a certain time.

The result is visible in the event form.
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Distance
The distance type of form heading makes it possible to calculate and store the distance between two
geolocalized resources comprised within an event.
Example: Calculate the distance traveled between the office and the customer for a work event.
You can then use the result in different VISUAL PLANNING functionalities.
see Distance type heading

Scheduling of events
The scheduling functionality minimizes the gaps between end and start dates of events.
The events that are scheduled must be the hourly type.

To schedule events according to location, select the events to schedule > right-click on one of the
selected events > Geolocation > Scheduling.
The following window is displayed:

Specify the following characteristics:
Tour start time
If the tour start time is specified, the first event to schedule will start at the time defined in this field.
Otherwise the tour start time will begin at the time of the first event.
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Alignment
Define the alignment value between the events once the calculation has been performed.
Example: If there are 2 events to schedule. The first event event 1 starts at 8 a.m. and ends at 10 a.m..
The journey time from event 1 to event 2 is 52 minutes. If the chosen alignment value is:
■ 0 minute: event 2 will start at 10.52 a.m.,
■ 5 minutes: event 2 will start at 10.55 a.m.,
■ 1 hour: event 2 will start at 11 a.m.,
Location of departure
If this field is defined, the calculation will start at the location defined in this field. Otherwise, the location
of departure will be the location of the first event.
Example: If the location of departure is your office, you must select the heading comprising the office’s
address in this field.
Location of the tour
Specify the heading that will be used for scheduling.
Show Map
Check this box to display the map after the calculation.
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Chapter II. RSS Feed
1. DEFINITION
The RSS FEED Module is an additional application enabling you to distribute a list of events
synchronously:
■ either for each resource,
■ or for a set of resources.
The module makes available an URL giving access to the RSS file.

2. TECHNICAL PREREQUISITES
The RSS FEED module was developed and validated for VISUAL PLANNING ENTERPRISE.
The RSS FEED module is contained in the VISUAL PLANNING kernel and an additional license is not
required in order to enable it.

3. CONFIGURATION
Each distribution address is attached to a dimension.
To configure you must define the Feed contexts to distribute.

Creating an RSS FEED
Go to Settings > Configuration block, click on RSS FEED.
The editing window opens.
Right-click on RSS FEED > Create an RSS FEED > Choose the dimension.
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The corresponding part is then enabled:
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Specify the characteristics of the feed context, then confirm by clicking on the Validate button.
The following characteristics must be entered:
Name
Give the RSS FEED context a name.
Description
Give a description explaining the purpose of this feed. This data is optional.
History
This represents the creation date and time and the most recent change to the context, together with
the login of the user who performed these actions.
This property is updated automatically.
Enabled
Check or uncheck the box to respectively enable or disable the feed context.
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A feed for each resource
This box:
■ enables you to publish one URL for each resource in the filter below if it is checked (see below)
■ enables you to publish one URL for all the resources in the filter below if it is not checked. (See below)
Content
Choose from the headings and other event attributes the item or items that will define the Feed content.
Maximum number of items
Define the maximum number of items present in the feed.
Publication date
This is the date when the feed will be sent:
■ Event - Start date: the sending date is the event start date,
■ Event - End date: the sending date is the event end date,
■ History - Created on: the sending date is the event creation date,
■ History - Modified on: the sending date is the event modification date.
Title
Choose from the headings and other event attributes the item or items that will define the title of the
feed sent.
Events filter
This filter defines the events to which the Feed context applies.
You can:
■ select an existing filter,
■ or create a custom filter specific to the publication context. To do this, select Customized.
The content visible in the feed corresponds to the events visible via the two events and
resources filters.
Resource filter
This filter defines the resources to which the Feed context applies.
You can:
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■ select an existing filter,
■ or create a custom filter specific to the publication context. To do this, select Customized.
The content visible in the feed corresponds to the events visible via the two events and
resources filters.

Modifying an RSS FEED
To modify an existing RSS context, go to the Settings menu > Configuration block > RSS Feed, then
Click on the context to modify.
The corresponding part is then enabled. Modify the settings (see Creation of an RSS Feed), then click
on Validate to save any modifications.

Deleting an RSS FEED
To delete an RSS context, go to the Settings menu > Configuration block > RSS Feed, then Rightclick on the context to delete.
The following message appears:

Click on:
■ Yes, to definitively delete the context,
■ No to cancel the deletion.

4. USE
Displaying the URL
To display the distributing URL, Right-click on the publication > Display the URL.
There are two possible situations depending on whether the One feed for each resource box is checked
or not:
■ one URL for all the resources,
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■ one URL per resource.

In both cases, it is possible to copy-paste the URL or URLs to distribute them to users.

Distribution
There are several ways to access the information threads generated by an RSS FEED.
You can use:
■ a messaging software and receive this information at the same time as you consult your e-mails,
■ a Web browser and display the different information feeds in the form of a home page,
■ a specialized software for consolidation of RSS information threads, also known as a news reader
or feed aggregator.
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Chapter III. Send SMS
1. DEFINITION
The SEND SMS module is an additional functionality making it possible to send an SMS from VISUAL
PLANNING to any type of telephone number that accepts the SMS format (national or international).
It consists of:
■ a configuration of the SMS sending server,
■ a configuration interface accessible from VISUAL PLANNING (configuration of the structure of SMSs
and sending conditions),
■ triggering from the pop-up menu of VISUAL PLANNING events.

2. PREREQUISITES
Technical prerequisites
The SEND SMS module has been validated for the VISUAL PLANNING ENTERPRISE version.
This module requires:
■ an Internet connection,
■ registration with our partner ESENDEX.
In addition, the “MAIL to SMS” functionality (Situation 2 below) enables you to send SMSs automatically
via the Send Mail functionality. To use this functionality you must first set up the SMTP server for the
Send Mail module.
To use a different supplier for the MAIL TO SMS service, please contact our technical
department at sav@stilog.com

Functional pre-requisites
This module requires a text heading containing the recipient’s phone number, or a concatenation of the
phone number and the suffix making it possible to use Mail to SMS.
For optimum use, we recommend you use a Text or Multi-line Text type of form heading called VPSMS
in order to store the sending date and the sender’s login, instead of the event note.

3. DEFINING ADMINISTRATORS
Only users identified as “administrators” have access to the module’s configuration.
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A user is defined as a module administrator in the Admin Center, Modules menu > Right-click on the
SMS module > Modify > Administrators.

The planner “administrators” also have access to configuration of the SMS module.

4. CONFIGURATION
Configuration requires two actions:
■ configuration of the SMS sending server in the Admin Center,
■ configuration of the SMS sending contexts in VISUAL PLANNING.

Configuration of the Send SMS server
The server for sending SMSs is configured in the Admin Center.
In the list of modules, right-click on SMS > Modify.

Now click on Settings

STILOG IST, all rights reserved

25

Modules

You must now enter the settings for the SMS sending server.
Two technologies can be used:
■ Direct sending,
■ Mail to SMS.
Situation 1: Direct sending,
You must type in the following settings:
SMS.esendexNum
Enter the ESENDEX account number.
SMS.esendexPwd
Enter the ESENDEX password.
SMS.esendexUser
Enter the ESENDEX account login.
SMS.provider
Here you choose the technology to use. Select ESENDEX.
Other settings
All the other settings must be left empty.
Situation 2: Mail to SMS
The documentation for this functionality is available online by following this link.

STILOG IST, all rights reserved

26

Modules

You must type in the following settings:
SMS.mailDomain
Enter the domain name of the e-mail to convert to an SMS. Enter the echoemail.net value.
SMS.mailSender
Enter the e-mail address of the ESENDEX account that will perform the conversion from Mail to SMS.
SMS.mailSubject
Enter the subject of the e-mail to convert to an SMS.
Depending on the supplier and the chosen security level, this subject may or not be shown in the SMS
as a prefix.
SMS.provider
Here you choose the technology to use. Select MAILSMS.
Other settings
All the other settings must be left empty.

Configuration of the Send SMS context
You must configure at least one template for sending SMSs.
To do so, go to Settings > Configuration Block > VPSms.
If the Tools > SMS Configuration menu does not display, or displays grayed, this may be
because:
■ the module is incorrectly installed,
■ the module you are using does not have the prerequisites,
■ the access profile is not defined as a planner administrator.
The editing window opens, right-click on VPSms Templates > Create a VPSms Template.
The corresponding pane is enabled:
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You must now define the template’s characteristics.
Name
Enter this template’s name.
Description
Enter a description for the template. This data is optional.
History
This represents the creation date and time and the most recent change to the template, together with
the login of the user who performed these actions.
This property is updated automatically.
Content
This is a free text zone which contains the body of the message.
You can insert one or more planner entities into this text (event attributes and headings).
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Events filter
This is the event filter that will determine whether or not it is possible to use the template to send the
selected event by SMS (see Use).
Only events complying with this filter can use the template.
More than 160 characters
Check this box to split the SMS content every 160 characters. Several SMS are then sent.
Mark the sending
Check this box to save the date and time the event was sent by SMS, and the login of the user who
sent it. This information is saved in the event form’s VPSMS heading if this heading exists, otherwise
it will be saved in the event note.
Recipients
This is a Text type of heading to be chosen from those that exist:
■ The number can contain space, period (.), plus (+) and minus (-) characters.
■ The number must start with 06 (or 07) or with an international code (e.g. 0041 or +33).
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5. USE
Manual sending of an SMS
The SMS can only be sent manually. To send SMSs automatically, you must use the "Mail to
SMS" module (see below).
To execute the module, right-click on one or more events > Send an SMS > Choose the template.
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Send using Mail to SMS
Among other things, this functionality enables you to send SMSs automatically.
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To do so:
■ Configure the SMS module in the Admin Center as above,
■ A Text type of heading containing the phone number concatenated with the "@echoemail.net” suffix
must exist.
■ An e-mail is sent instead of a direct SMS. You must therefore configure a Mail template.
Once these settings have been created, the content of the SMS is configured in the Send Mail module
(see Sending e-mails).
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Chapter IV. Sending e-mails
1. DEFINITION
You can use VISUAL PLANNING to send e-mails.
Depending on the version, this is done:
■ From a resource:
▪ Sending an empty e-mail to write,
▪ Sending an e-mail with the print-out of a resource in PDF format as an attachment,
■ From an event:
▪ Manually or automatically sending a pre-formatted e-mail.
The planner administrator can choose the method for sending e-mail, using:
■ either a messaging software,
■ or an SMTP server.
A SMTP server is required in order to send e-mail automatically, and this is only possible with
the VISUAL PLANNING ENTERPRISE version.

2. SENDING E-MAIL FROM A RESOURCE
DEFINITION
VISUAL PLANNING enables you to send e-mail from a planner resource. You can send:
■ an empty e-mail to write,
■ or an e-mail with the print-out of the resource in PDF format as an attachment.
The recipient’s address can be defined in the planner by the content of a heading, or else entered by
the user when sending.
The subject of the e-mail and a text message can also be typed in. Additional documents can also be
attached to the message.

PREREQUISITES
Technical prerequisites
A messaging software must be installed on the client workstation sending the e-mail.
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This functionality has been validated for MICROSOFT OUTLOOK OFFICE 2007 and later.
The SMTP server must be accessible from the VISUAL PLANNING server.
Functional pre-requisites
This functionality has no indispensable pre-requisites.
However, for optimum use it is recommended to create for each dimension using sending of e-mail:
■ One or more Text headings containing the e-mail addresses of the message recipients.
■ A resource heading called VPMAIL whose type is:
▪ Text,
▪ Multi-line text,
▪ Boolean.
The last type enables you to store the date and time the last e-mail was sent from each resource, as well
as the sender’s login. In the case of Boolean headings, they are checked once the e-mail has been sent.
SMTP server
In this case, you must define the e-mail address of the sending user.
To do so, go to the Admin Center, then in the Users section, Right-click on the user > Modify.
Then in the window that opens, type in the User’s E-mail address and finally Validate.

CONFIGURATION
Sending an empty e-mail to write,
This functionality does not require any configuration.
Sending a resource print-out by e-mail
This functionality uses the configuration created for printing a resource .
This configuration is saved in the favorite display when it is saved. It can also be modified each time
it is used (see below)
To send e-mail using an SMTP server, you must define its configuration (see below).

USE
Sending an empty e-mail to write,
To send an e-mail, Right-click on a resource > Send an e-mail.
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If one or more of the resource’s headings contains one or more e-mail addresses, they will be included
directly as addresses of e-mail recipients.
The remaining definition of the e-mail and the method for sending it depend entirely on the messaging
software.
In the case of messaging software
In the ONE and ENTERPRISE versions (if the SMTP server is not configured), each time you send email, the messaging software window opens so you can:
■ Fill or modify the different e-mail fields (subject, mail body, etc.)
■ Validate sending.
In the case of an SMTP server
In ENTERPRISE version, if the SMTP server is configured, and e-mail is sent from a resource, a VISUAL
PLANNING mailer opens automatically instead of the messaging software.
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The sender’s e-mail address is the address of the user defined in the ADMIN CENTER.
Sending a resource print-out by e-mail
This functionality enables you to send an e-mail with an attachment: a PDF file containing a print-out
of the selected resource.
In the case of multiple resource selection, a single PDF file will be sent to all the selected
resources. The file will contain a print-out of the selected resources, with one resource on each
page.
To use this functionality, just right-click on a resource > Send > PDF by e-mail.
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The print configuration window is displayed:

By default, the print settings are the settings saved in the favorite display.
You can modify the print settings if necessary.
Then click on the Validate button.
There are then two possible situations depending on whether or not you are using an SMTP server:
■ either a messaging software sends the e-mail. This is the case in the ONE and ENTERPRISE
versions (if the SMTP server is not configured).
■ or an SMTP server sends the e-mail. This functions only in the ENTERPRISE VERSION and only
if the SMTP server has been configured.
In the case of messaging software
In the ONE and ENTERPRISE versions (if the SMTP server is not configured), each time you send email, the messaging software window opens so you can:
■ Fill or modify the different e-mail fields (subject, mail body, etc.)
■ Validate sending.
In the case of an SMTP server
In ENTERPRISE version, if the SMTP server is configured, and e-mail is sent from a resource, a VISUAL
PLANNING mailer opens automatically instead of the messaging software.

STILOG IST, all rights reserved

37

Modules

The sender’s e-mail address is the address of the user defined in the ADMIN CENTER.

3. SENDING AN E-MAIL FROM AN EVENT
VISUAL PLANNING enables you to send e-mails from an event or a selection of events.
Depending on the version, this is done:
■ Manually via a messaging software (ONE or ENTERPRISE version),
■ Manually via an SMTP server (ENTERPRISE version only),
■ Automatically via an SMTP server (ENTERPRISE version only),
These e-mails use predefined templates.

Prerequisites
Technical prerequisites
A messaging software must be installed on the client workstation sending the e-mail.
This functionality has been validated for MICROSOFT OUTLOOK OFFICE 2007 and later.
The SMTP server must be accessible from the VISUAL PLANNING ENTERPRISE server when sending
e-mails by SMTP and/or automatically.
Functional pre-requisites
To use this functionality you must create at least one template for sending e-mails.
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However, for optimum use it is recommended to create in a form for the event using sending of e-mail:
■ A heading called VPMAIL:
▪ Text type,
▪ Multi-line Text type,
▪ or Boolean type.
The last type enables you to store the date and time the last e-mail was sent from each resource, as well
as the sender’s login. In the case of Boolean headings, they are checked once the e-mail has been sent.

Defining administrators
An administrator of this functionality is a user who will be able to configure the templates for sending
e-mails.
This administrator depends on the VISUAL PLANNING version.
In the ONE version
The ONE version only allows one user to access VISUAL PLANNING.
This user has the rights to configure templates for sending e-mails.
In the ENTERPRISE version
In the ENTERPRISE version, the VISUAL PLANNING administrator ("admin” user) can still configure
the templates for sending e-mails.
In addition it is possible to configure other administrators for this functionality, i.e. users who will be able
to configure templates for sending e-mails.
To do so, go to the Admin Center, then in the list of Modules, Right-click on E-Mail > Modify.
The following window opens:

Now choose the users who are administrators of the functionality.
You must then click the Validate button.
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Configuring an e-mail template
You must configure at least one template for sending e-mails.
To do so, go to Settings > Configuration Block > VPMail.
The editing window opens. Right-click on VPMail Templates > Create a VPMail template

The right-hand pane is then enabled:
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Now you should define the template’s characteristics and click on Validate to confirm creation of the
template.
Name
Give the template a name.
Description
Give the template a description. This data is optional.
History
This represents the creation date and time and the most recent change to the template, together with
the login of the user who performed these actions.
This property is updated automatically.
Content
This is a free text zone which contains the body of the message.
You can insert one or more planner entities into this text:
■ Dimension or form headings,
■ Valuation items,
■ Event attributes (including history),
■ The global variables $USERNAME and $USERFULLNAME,
■ The parent event’s variables if the e-mail is sent from a child event.
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HTML Format
Check this box to generate the e-mail in HTML format.
Join attached files
If Attachment type headings exist, it is possible to attach them to the e-mail as attachments.
The Attachment type headings that will be associated with the e-mail are those of the event’s dimensions
or the dimensions of its form.
Recipients
Choose the text or multi-line headings that contains the recipient’s e-mail address.
These headings can contain several addresses separated by a semi-colon. In the case of a multi-line
type of heading, if the e-mail addresses are separated by line returns, they will be replaced by ”;”.
Send an invitation
Check this box to send an invitation to the message’s recipients.
They will then be able to save the invitation in their messaging software and send an answer to the
e-mail’s sending address, but they will not be able to suggest other dates modifying those in VISUAL
PLANNING.
Subject
This is a free text zone which contains the subject of the message.
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You can insert one or more planner entities into this text:
■ Headings for dimension and/or form headings,
■ Values of the selected event,
■ Valuation items,
■ The global variables $USERNAME and $USERFULLNAME,
■ The parent event’s variables if the e-mail is sent from a child event.
Events filter
Define the event filter that will determine whether or not it is possible to use the template to e-mail the
selected event.
Only events complying with this filter can use the template.
Mark the sending
Check this box to save the date and time the e-mail was sent, and the login of the user who sent it.
Open mailer
Check this box to see the mailer, integrated into VISUAL PLANNING, before the e-mail is sent.
If several events are selected, a mailer opens for each selected event.
Sender hidden copy
This setting is only available if the SMTP server has been configured.
This is only useful for automatic sending of e-mails.
Event creation/modification
Check this box to enable triggering of the context during creation and/or modification of events.
Enabled
This setting is only available if the SMTP server has been configured.
This is only useful for automatic sending of e-mails.
Sender e-mail address
This setting is only available if the SMTP server has been configured.
This is only useful for automatic sending of e-mails.
Triggers
This setting is only available if the SMTP server has been configured.
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This is only useful for automatic sending of e-mails.

Configuring the SMTP server
SMTP server
The SMTP server is configured in the Admin Center.
In the list of modules, right-click on Mail > Modify > Settings.
The following window opens:

You must then enter the SMTP server settings:
■ MAIL.receiveProtocol : Define the protocol (imap or pop3),
■ MAIL.receiveServer : Address of incoming account server (pw entered in the Admin center >
External access settings),
■ MAIL.receiveSSL: to enable or disable SSL reception,
■ SMTP.password: the SMTP account password,
■ SMTP.port: the SMTP server port,
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■ SMTP.server: the SMTP server name,
■ SMTP.SSL: send via SSL or not,
■ SMTP.TLS: send via TLS or nor,
■ SMTP.user: SMTP account name: this can be an e-mail address.
Sender
You must define the sender’s e-mail address.
The sender is the VISUAL PLANNING user.
To do so, go to the Admin Center, then in the Users section, Right-click on the user > Modify.
■ Enter the user’s E-mail address,
■ and finally Validate.

Manual sending of e-mail
Choosing the template
To send an e-mail, Right-click on one or more events > Send an e-mail.

There are several possibilities:
■ If no template corresponds to the event that must be sent, nothing happens and the e-mail is not sent,
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■ If one template corresponds to the event that must be sent, sending of the e-mail begins.
■ If several e-mail templates correspond to the event that must be sent, the user is given the choice
of which template to use.
Select the template to use to e-mail the event, then click on Validate.
Sending e-mail
There are two possible situations depending on whether or not you are using an SMTP server:
■ If the SMTP server is not configured, a messaging software will be used to send the e-mail. This is
the case in the ONE and ENTERPRISE versions (if the SMTP server is not configured).
■ If the SMTP server is configured, it sends the e-mail. This functions only in the ENTERPRISE
VERSION and only if the SMTP server has been configured.
In the case of messaging software
In the ONE and ENTERPRISE versions (if the SMTP server is not configured), the messaging software
window opens so you can:
■ Fill or modify the different e-mail fields (subject, e-mail body, etc.)
■ Validate sending.
In the case of an SMTP server
In ENTERPRISE version, if the SMTP server is configured the e-mail is send directly from VISUAL
PLANNING, without opening a messaging software.
If the Open Mailer option is checked, the following window appears before the e-mail is sent, filled in
according to the settings of the chosen template:

The sender’s e-mail address is:
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■ either the user defined in the Admin Center if the e-mail is sent manually,
■ or the address defined in the e-mail’s context if the e-mail is sent automatically.
Event marking
If the e-mail template uses the functionality to mark sending of the e-mail, the history and name of the
e-mail’s context are stored in the sent event:
■ in a form heading called VPMAIL, if it exists. (see Functional pre-requisites above).
■ in the events note if this heading does not exist.

Automatic sending of e-mail
Configuration
Configuration consists of three settings:
■ configuration of the SMTP server,
■ configuration of triggering of contexts for sending e-mails,
■ management of the automation service (see below).
Management of the automation service
Enabling of the service in the planner
In the Admin Center, right-click on the relevant planner > Modify.
Check the option Enable 'Send mail'.
Starting and stopping the service
In the Admin Center, right-click on the "Send Mail" service then:
■ Start service to start the service,
■ Stop the service to stop the service. A stopped service is grayed.
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Automatic start
You can define whether the sending service is started when the VISUAL PLANNING server opens or
restarts.
To do so, right-click on the "Send Mail” service > Modify.
In the window that is displayed, check the Automatic start box.

Sending e-mail
Use of hierarchies is transparent on the planner.
For each e-mail sending template that has at least one trigger, all the events corresponding to the filter
defined in the template are sent.
The only action visible in the planner is therefore marking of the sending history in the event, if it has
been enabled.
The sender’s e-mail address is the address defined in the e-mail’s context if the e-mail is sent
automatically.
Event marking
If the e-mail template uses the functionality to mark sending of the e-mail, the history and name of the
e-mail’s context are stored in the sent event:
■ in a form heading called VPMAIL, if it exists. (see Functional pre-requisites above).
■ in the events note if this heading does not exist.
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Chapter V. VPPublipost mail merge
1. DEFINITION
The VPPUBLIPOST mail merge module enables you to generate one or more documents:
■ in WORD format (.DOC,.DOCX) if the template used is a Word document,
■ in PDF format if the template used is a Pentaho document,
■ in *.PRPT format if the PENTAHO application is used.
The documents are generated using one or more events. You can generate as many documents as
there are selected events. You can also generate a single document for several selected events.

Using Word
In this case, the mail merge uses a WORD template and a database made up of fields (the information
to be retrieved from VISUAL PLANNING).
In concrete terms the tool functions using the same principles as the Microsoft Word mail merge
functionality:
With a document template in *.DOC or *.DOCX format, (this template must include the mail merge
fields, see Configuration) as well as a data source: one or more VISUAL PLANNING events.

Using Pentaho
In this case, the mail merge is managed in a tool separate from VISUAL PLANNING - Pentaho Report
Designer - but still using the fields present in VISUAL PLANNING.
The mail merge uses a PRPT template.

2. PREREQUISITES
Technical prerequisites
The VPPUBLIPOST mail merge functionality was developed and validated for:
■ VISUAL PLANNING ENTERPRISE,
■ Microsoft Word 2003, 2007 and 2010. It requires a version of Microsoft WORD including VISUAL
BASIC FOR APPLICATIONS (VBA),
■ PENTAHO REPORT DESIGNER version 5.4 maximum.
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Functional pre-requisites
The VPPUBLIPOST mail merge functionality requires at least one VPPUBLIPOST template to be
defined in VISUAL PLANNING.

3. CONFIGURATION
Creating a mail merge template
Before starting to configure Mail Merge on VISUAL PLANNING, you must create a WORD or
PENTAHO destination document. This template must contain the empty spaces that VISUAL
PLANNING will fill as necessary.
The settings of the VPPublipost module can be accessed from the module configuration window.
Go to the Settings tab > Configuration Block > Click on VPPublipost
In the window that is displayed, right-click on VPPublipost Templates > Create a Mail Merge template.

The corresponding part is then enabled:
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Specify the characteristics of the feed context, then confirm by clicking on the Validate button.
The following characteristics must be entered:
Name
Give this template a name.
Description
Give a description of this mail merge template. This data is optional.
History
This represents the creation date and time and the most recent change to the template, together with
the login of the user who performed these actions.
This property is updated automatically.
Attach the result to the headings
This enables you to choose an Attachment type of form heading to which the mail merge result will
be attached.
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For each mail merge, the result is attached to this heading. If it accepts several attached files, the
results of the most recently generated mail merges will be conserved. The most recent appears at the
top of the list.
In the case of Pentaho, the heading must be in file download.

If no heading is defined, a window asking you to open the generated files will be displayed after the
mail merge.
Events filter
Choose the event filter that will determine whether or not it is possible to use the created mail merge
template (see Use). Only events complying with this filter can use the template.
Properties to publish
This functionality limits the number of data items that will be available in the merge fields when entering
values originating from VISUAL PLANNING.
If no properties are published, all the VISUAL PLANNING data will be sent and can be used as merge
fields.
Backup directory
If the mail merge result is not attached to a heading, or if the Attachment heading selected above is
local, define a directory where all the edited mail merges will be saved.
This directory must be accessible for all users.
Attributes that define the path
If the mail merge result is not attached to a heading or if the Attachment heading selected above is
local, you can specify the tree structure of directories where the mail merge result is saved, thanks to
the dimension headings.
Each selected attribute will constitute a folder in the backup directory.
Application
This field enables you to choose the source of the mail merge template: MS Word or Pentaho Report.
Single destination file
This functionality will enable you to generate a single document for all the source data used.
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In other words, if you check this box, instead of obtaining a document for each event, VISUAL
PLANNING generates a single document for all the selected events.
Save as PDF
To specify that the result must be generated in the PDF format.
It is only operational for Word 2010 and Word 2007 with an add-on.
Timestamp
Check this box to add a yyyymmdd_hhmmss suffix at the end of the file when it is generated.
Mail merge template file
To select the mail merge template file using the button

:

Two situations may arise, depending on the origin of the mail merge template.
Using MSWord
If the mail merge template is from MS Word, you should click this button

.

This starts Word and enables you to enter the values from the planner which will be used for the mail
merge. When you save the Word file after defining your mail merge, the following dialog is displayed:

To take account of the new definition, you must of course answer yes.
Using Pentaho
If the mail merge template is from Pentaho, you will enter the values from the planner directly in the
Pentaho tool in VISUAL PLANNING.
However, it is possible to download the file by clicking on the button

.

Once the mail merge context has been configured you must export it in XML format by right-clicking on it:
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Then, in the Pentaho tool, you must add the XML file exported from VISUAL PLANNING by clicking
on Data > Add Datasource > XML:

The following window opens:
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Click on the button
on the icon

to choose the XML file exported from VISUAL PLANNING, and then

to add a value.

Finally add the /*/* value in the note field right at the bottom:

Now click on OK or Preview to verify that the data is accessible.
Make the required modifications and matching operations on Pentaho and save your PRPT file.
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Once your file has been saved on Pentaho, you must return to the mail merge template to
attach the .prpt file to it by clicking on this button

.

To learn more about how to use the Pentaho software, see Pentaho

Event creation/modification
In a situation where you choose to store the file generated by the mail merge in an attachment type
of form heading, it is possible to generate mail merge documents automatically by checking the Event
creation/modification box.
A mail merged file will be generated and stored in the form heading whenever an event is created or
modified.
For this to take place, the files in the attachment type of heading must be downloaded.

Modifying a mail merge template
To modify an existing template, go to the Settings menu > Configuration block > RSS Feed, then
Click on the template to modify.
The corresponding part is then enabled. Modify the settings (see Creating a mail merge template), then
click on Validate to save any modifications.

Deleting a mail merge template
To delete a template, go to the Settings menu > Configuration block > RSS Feed, then Right-click
on the template to modify.
The following message appears:

Click on:
■ Yes, to definitively delete the context,
■ No to cancel the deletion.
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4. USE
To use the mail merge template, right-click on one or more events, then click on Mail Merge in the
pop-up menu
There are two possible options:
■ If no template corresponds to the event, then it is not possible to click on Mail Merge.
■ If one or more templates do correspond to the event, then it is possible to choose from the proposed
list.

A message is displayed offering to open the generated document(s).
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Chapter VI. VPWhatsUp
1. DEFINITION
The VPWhatsUP module enables users of the same planner to discuss and share information about
resources and events.
When a discussion is created, only users authorized to view the discussions will be able to participate.
The admin user will be able to see all the VPWhatsUP discussions created.

2. CONFIGURATION
All of a planner’s users can create VPWhatsUP discussions and interact.

Creating a VPWhatsUP discussion
Click on the button

located top right of the planner.

The following window appears:
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In the window that is displayed, click on the button
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You can now define the characteristics of the discussion which consist of:
Name
Give this new discussion a name.
Description
Give the discussion a description. This data is optional.
History
This represents the creation date and time and the most recent change to the Discussion, together with
the login of the user who performed these actions.
This property is updated automatically.
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Specifics
Select the planner users to be included in the discussion.
They will then be able to participate.
It is not possible to create several discussions with the same users.

Modifying a discussion
To modify a discussion, Click on the discussion > Click on the button
window.

to display the configuration

Modify the discussion parameters (see Creating a discussion) and click on the Validate button to
validate the modifications.

Deleting a discussion
To delete a discussion, Click on the discussion > Click on the button

to delete the discussion.

The discussion is deleted immediately. There is no warning window before deletion.

3. USE
Visualization
On the rich client
When you are logged into the planner, to see a discussion click on this button
discussions. Those who have unread discussions are displayed in italics.
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If several discussions have been created, they will be represented below each other.
An open discussion window does not prevent you from browsing the planner.

On VPPORTAL
When you are logged into VPPORTAL, to see a discussion click on this button
to see the
discussions. Those who have unread discussions have a little red dot indicating the number of unread
lines.

STILOG IST, all rights reserved

63

Modules

If several discussions have been created, they will be represented below each other.
An open discussion window does not prevent you from browsing VPPORTAL.

On VPGO
When you are logged into the planner, to see a discussion click on this button
discussions. Those who have unread discussions are displayed in italics.
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If several discussions have been created, they will be represented below each other.
An open discussion window does not prevent you from browsing the planner.

New items in a discussion
If new items have been added by other users, the icon located top right will be displayed as follows:
■
■

On the rich client:

,

On VPPORTAL:
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■

On VPGO:

The items sent will be displayed with the user’s full name and login as well as the date (or the time
when the item was sent if it is the current date).
When opening the planning, the missed messages will also be notified in the same way.

Entering a text
You can type in unrestricted text in a discussion. To do so, go to the writing window, enter your text and
validate by clicking on the Send button.

Share a resource via the discussion
The links to a resource are only available on the rich client.

You can share the properties of a resource via the discussion. To do so, go to a Resources view or
a Schedule view.
1. Drag the resource row to the zone for attaching files in the discussion window. The attached file will
then be positioned in the bottom part of the window. To send it, write an accompanying text in the
writing zone and click on the Send button,
2. Simply click on the link to open the resource editor.
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Share an event via the discussion
The links to an event are only available on the rich client.

You can share the properties of an event via the discussion. To do so, go to a representative of the
events (except on the Events Map view).
1. Drag the resource row to the zone for attaching files in the discussion window. The attached file will
then be positioned in the bottom part of the window. To send it, write an accompanying text in the
writing zone and click on the Send button,
2. Simply click on the link to open the event.
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Discussion history
The discussion history is conserved for 12 sliding hours, or when the VISUAL PLANNING application
server starts up.
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Chapter VII. Web Calendars
1. DEFINITION
The Web Calendars Module is an additional application enabling you to distribute a list of events
synchronously:
■ either for each resource: in the case of the individual diary,
■ or for a set of resources: in the case of a team diary.
The module makes available an URL giving access to a *.ICS file.
The standard used for *.ICS files is the ICalendar V2 standard.
To improve readability, from now on we will call the processed ICAL entities “Meetings”.

The Web Calendars module is an optional feature. If this option is not taken up, the
corresponding menus will not be visible in VISUAL PLANNING.

2. TECHNICAL PREREQUISITES
The Web Calendars Module was developed and validated for:
■ VISUAL PLANNING ENTERPRISE,
■ ICAL, version 2 or later.

3. INSTALLATION
A license number is required in order to install this module.
To obtain a license number for the Web Calendars module, contact the sales department:
■ by telephone on +33 (0) 1 47 29 99 69
■ or by e-mail at commercial@stilog.com
To install the module go to the ADMIN CENTER > Modules > Right-click on ICAL > Save the license.
Follow the instructions.
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The number of licenses you have acquired corresponds to the number of URLs you can use.
E.g.: if you have 10 ICAL licenses, the first 10 URLs used will take the 10 licenses.

4. CONFIGURATION
Each ICAL context is attached to a dimension.
To configure you must define the ICAL contexts to distribute.

Creating a publication
Go to Settings > Configuration block, click on Web Calendars.
The editing window opens.
Right-click on Web Calendars > Create a Web Calendar > Choose the dimension.
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The corresponding part is then enabled:
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Specify the characteristics of the context, then confirm by clicking on the Validate button.
The following characteristics must be entered:
Name
Give the publication context a name.
Description
Give a description explaining the purpose of this flow. This data is optional.
History
This represents the creation date and time and the most recent change to the context, together with
the login of the user who performed these actions.
This property is updated automatically.
Enabled
Check or uncheck the box to respectively enable or disable the flow context.
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Display short names
Check this box to display the names of dimensions to which the headings to display belong, or the
names of the VISUAL PLANNING entities.
Example: Start Day: 11/24/2015 or Name: MARTIN
One calendar for each resource
This box:
■ enables you to publish one URL for each resource in the filter below if it is checked,
■ enables you to publish one URL for all the resources in the filter below if it is not checked.
Categories
If necessary, choose from the headings and other event attributes the item or items that will define the
Meeting category.
This category must be the same as the category in your calendar. Otherwise, there will be a
category without a color.
Content
Choose from the headings and other event attributes the item or items that will define the Meeting
content.
Position
Choose from the headings and other event attributes the item or items that will define the Meeting
position.
This position will be displayed in the calendar Location attribute.

Meeting manager
Choose from the headings and other event attributes the item or items that will define the Meeting
manager.
This meeting manager will be visible in Planning mode and does not have to be an e-mail
address.

STILOG IST, all rights reserved

73

Modules

Participants
Choose from the headings and other event attributes the item or items that will define the Meeting
participants.
This meeting manager will be visible in Planning mode and does not have to be an e-mail
address.
Subject
Choose from the headings and other event attributes the item or items that will define the Meeting
subject.
Events filter
This filter defines the events to which the publication context applies.
You can:
■ select an existing filter,
■ or create a custom filter specific to the publication context. To do this, select Customized.
The Meetings available in the *.ICS file correspond to the events visible via the two events
and resources filters.
Resource filter
This filter defines the resources to which the publication context applies.
You can:
■ select an existing filter,
■ or create a custom filter specific to the publication context. To do this, select Customized.
The Meetings available in the *.ICS file correspond to the events visible via the two events
and resources filters.
Intersect the period
The period defines the events to which the publication context applies. (See Time period)

Modifying a publication
To modify an existing web calendar, go to the Settings menu > Configuration block > Web Calendars,
then Click on the context to modify.
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The corresponding part is then enabled. Modify the settings (see Creation of a web calendar), then
click on Validate to save any modifications.

Deleting a publication
To delete an existing web calendar, go to the Settings menu > Configuration block > Web Calendars,
then Click on the context to delete.
The following message appears:

Click:
■ Yes to confirm the deletion,
■ No to cancel.

5. USE
Displaying the URL
To display the distributing URL, Right-click on the publication > Display the URL.
There are two possible situations depending on whether the One calendar for each resource box is
checked or not:
■ one URL for all the resources,

■ one URL per resource.
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In both cases, it is possible to copy-paste the URL or URLs to distribute them to users.

Reading the calendar
Numerous applications can read *.ICS files, including:
■ MICROSOFT OUTLOOK 2007 and later: https://support.office.com/fr-fr/article/utiliser-le-calendrierdans-outlook-com-8cfd8a5e-de9a-4468-9225-8611c8c8c7b0
■ GOOGLE CALENDAR:
%3DDesktop&hl=fr

https://support.google.com/calendar/answer/37100?co=GENIE.Platform

■ APPLE ICAL: https://support.apple.com/fr-fr/guide/calendar/icl1022/mac
■ MOZILLA: http://www.mozilla.org/projects/calendar
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