Layout and display
Table of Contents

I. Main Window ........................................................................................................................................... 1
   1. DEFINITION ....................................................................................................................................... 1
   2. LIST OF WINDOW ELEMENTS ........................................................................................................ 1
      Quick Access Bar ......................................................................................................................... 1
      Menu Bar ......................................................................................................................................... 1
      Windows ......................................................................................................................................... 2
      Status bar .................................................................................................................................. 2
      Pop-up menu .............................................................................................................................. 4

II. Menu Bar ................................................................................................................................................. 5
   1. DEFINITION ....................................................................................................................................... 5
   2. PLANNER MENU ............................................................................................................................. 5
      Planner block .......................................................................................................................... 5
      Printing block ......................................................................................................................... 5
      Export block .......................................................................................................................... 6
      Import block .......................................................................................................................... 6
      Exit block .................................................................................................................................... 7
   3. SETTINGS MENU .......................................................................................................................... 7
      Windows block .......................................................................................................................... 7
      Configuration block ............................................................................................................... 7
   4. EDIT MENU ......................................................................................................................................... 7
      General block .......................................................................................................................... 8
      Events block .......................................................................................................................... 8
      Links block .......................................................................................................................... 9
      Resources block .................................................................................................................... 9
      Events Reports block ........................................................................................................... 9
   5. DISPLAY MENU ................................................................................................................................ 9
      Configuration block .................................................................................................................... 10
      Favorite Displays block ........................................................................................................ 10
      Predefined views block ........................................................................................................ 10
      Rows block .................................................................................................................................. 10
      Mode block .................................................................................................................................. 11
      Resources block .................................................................................................................... 11
      Planner block .......................................................................................................................... 12
      Diary block .................................................................................................................................. 12
      Events Reports block ............................................................................................................ 12
   6. FILTERS MENU .................................................................................................................................. 13
      Dimension Filters block ........................................................................................................ 13
      Events Filters block ................................................................................................................ 13
      Free Periods block .................................................................................................................. 14

III. Quick Access Bar .......................................................................................................................... 15
   1. DEFINITION ....................................................................................................................................... 15
   2. LIST OF FUNCTIONS ..................................................................................................................... 15
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layout and display</td>
<td></td>
</tr>
<tr>
<td>Favorite display</td>
<td>15</td>
</tr>
<tr>
<td>Refresh</td>
<td>15</td>
</tr>
<tr>
<td>Undo / Redo</td>
<td>15</td>
</tr>
<tr>
<td>Language</td>
<td>16</td>
</tr>
<tr>
<td>Change password</td>
<td>16</td>
</tr>
<tr>
<td>Display VPWhatsUP view</td>
<td>16</td>
</tr>
<tr>
<td>Weather</td>
<td>17</td>
</tr>
<tr>
<td>IV. Duration Bar</td>
<td>18</td>
</tr>
<tr>
<td>1. DEFINITION</td>
<td>18</td>
</tr>
<tr>
<td>2. CONFIGURATION</td>
<td>18</td>
</tr>
<tr>
<td>3. USE</td>
<td>18</td>
</tr>
<tr>
<td>Views</td>
<td>18</td>
</tr>
<tr>
<td>Manipulation</td>
<td>19</td>
</tr>
<tr>
<td>Cut the time bar in the Schedule and Gantt Events views</td>
<td>19</td>
</tr>
<tr>
<td>Printing</td>
<td>19</td>
</tr>
<tr>
<td>V. Smart Toolbar</td>
<td>20</td>
</tr>
<tr>
<td>1. DEFINITION</td>
<td>20</td>
</tr>
<tr>
<td>2. ENABLING</td>
<td>20</td>
</tr>
<tr>
<td>3. DESCRIPTION</td>
<td>20</td>
</tr>
<tr>
<td>Open</td>
<td>20</td>
</tr>
<tr>
<td>Refresh</td>
<td>20</td>
</tr>
<tr>
<td>Undo / Redo</td>
<td>21</td>
</tr>
<tr>
<td>Favorite displays</td>
<td>21</td>
</tr>
<tr>
<td>Printing</td>
<td>21</td>
</tr>
<tr>
<td>Import / Export</td>
<td>21</td>
</tr>
<tr>
<td>Global Settings</td>
<td>22</td>
</tr>
<tr>
<td>Resource filters</td>
<td>22</td>
</tr>
<tr>
<td>Events filters</td>
<td>22</td>
</tr>
<tr>
<td>Preferences</td>
<td>23</td>
</tr>
<tr>
<td>VI. View</td>
<td>25</td>
</tr>
<tr>
<td>1. DEFINITION</td>
<td>25</td>
</tr>
<tr>
<td>2. CHARACTERISTICS</td>
<td>25</td>
</tr>
<tr>
<td>3. CONFIGURATION</td>
<td>25</td>
</tr>
<tr>
<td>Creating a view</td>
<td>25</td>
</tr>
<tr>
<td>Modifying a view</td>
<td>26</td>
</tr>
<tr>
<td>Deleting a view</td>
<td>27</td>
</tr>
<tr>
<td>4. USE</td>
<td>28</td>
</tr>
<tr>
<td>Layout of views</td>
<td>28</td>
</tr>
<tr>
<td>Title bar and applied filters</td>
<td>28</td>
</tr>
<tr>
<td>Printing a view</td>
<td>28</td>
</tr>
<tr>
<td>Synchronizing views</td>
<td>29</td>
</tr>
<tr>
<td>VII. Layout of views</td>
<td>30</td>
</tr>
<tr>
<td>1. DEFINITION</td>
<td>30</td>
</tr>
</tbody>
</table>
## Layout and display

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. USE</td>
<td>30</td>
</tr>
<tr>
<td>Shifting a view</td>
<td>30</td>
</tr>
<tr>
<td>Superimposing views</td>
<td>30</td>
</tr>
<tr>
<td>Pinning a view</td>
<td>30</td>
</tr>
<tr>
<td>VIII. Resources View</td>
<td>32</td>
</tr>
<tr>
<td>1. DEFINITION</td>
<td>32</td>
</tr>
<tr>
<td>2. CONFIGURATION</td>
<td>32</td>
</tr>
<tr>
<td>Creating a view</td>
<td>32</td>
</tr>
<tr>
<td>Modifying a view</td>
<td>33</td>
</tr>
<tr>
<td>Deleting a view</td>
<td>34</td>
</tr>
<tr>
<td>3. DISPLAY SETTINGS</td>
<td>35</td>
</tr>
<tr>
<td>Access</td>
<td>35</td>
</tr>
<tr>
<td>Resources tab</td>
<td>36</td>
</tr>
<tr>
<td>Printing tab</td>
<td>41</td>
</tr>
<tr>
<td>Synchronization tab</td>
<td>46</td>
</tr>
<tr>
<td>4. USE</td>
<td>46</td>
</tr>
<tr>
<td>Tree mode</td>
<td>46</td>
</tr>
<tr>
<td>Layout of a Resources View</td>
<td>47</td>
</tr>
<tr>
<td>Sorting resources</td>
<td>47</td>
</tr>
<tr>
<td>Printing a Resources View</td>
<td>48</td>
</tr>
<tr>
<td>Favorite display</td>
<td>48</td>
</tr>
<tr>
<td>IX. Schedule View</td>
<td>49</td>
</tr>
<tr>
<td>1. DEFINITION</td>
<td>49</td>
</tr>
<tr>
<td>2. CONFIGURATION</td>
<td>49</td>
</tr>
<tr>
<td>Creating a view</td>
<td>49</td>
</tr>
<tr>
<td>Modifying a view</td>
<td>50</td>
</tr>
<tr>
<td>Deleting a view</td>
<td>51</td>
</tr>
<tr>
<td>3. DISPLAY SETTINGS</td>
<td>52</td>
</tr>
<tr>
<td>Access</td>
<td>52</td>
</tr>
<tr>
<td>Events tab</td>
<td>54</td>
</tr>
<tr>
<td>Planner tab</td>
<td>61</td>
</tr>
<tr>
<td>Resource rows tab</td>
<td>66</td>
</tr>
<tr>
<td>Workloads tab</td>
<td>71</td>
</tr>
<tr>
<td>Printing tab</td>
<td>73</td>
</tr>
<tr>
<td>Synchronization tab</td>
<td>78</td>
</tr>
<tr>
<td>4. USE</td>
<td>79</td>
</tr>
<tr>
<td>Tree mode</td>
<td>79</td>
</tr>
<tr>
<td>Layout of a Schedule view</td>
<td>80</td>
</tr>
<tr>
<td>Moving in the Schedule view</td>
<td>80</td>
</tr>
<tr>
<td>Sorting resources</td>
<td>80</td>
</tr>
<tr>
<td>Printing a Schedule view</td>
<td>80</td>
</tr>
<tr>
<td>Favorite display</td>
<td>80</td>
</tr>
<tr>
<td>X. Diary View</td>
<td>81</td>
</tr>
</tbody>
</table>
1. DEFINITION ......................................................................................................................... 81
2. CONFIGURATION ................................................................................................................ 81
   Creating a view ................................................................. 81
   Modifying a view ............................................................. 82
   Deleting a view ................................................................. 83
3. DISPLAY SETTINGS .............................................................................................................. 84
   Access .................................................................................. 84
   Diary tab ............................................................................. 87
   Events tab ........................................................................... 89
   Printing tab ........................................................................ 98
   Synchronization tab ............................................................ 102
4. USE ................................................................................................................................. 103
   Creating a Diary View event .............................................. 103
   Event display mode ............................................................ 103
   Layout of a Diary View ....................................................... 103
   Printing a Diary View ........................................................ 103
   Favorite display ................................................................. 103

XI. Events View .................................................................................................................. 105
1. DEFINITION ..................................................................................................................... 105
2. CONFIGURATION ............................................................................................................. 105
   Creating a view ................................................................. 105
   Modifying a view ............................................................. 106
   Deleting a view ................................................................. 107
3. DISPLAY SETTINGS ........................................................................................................... 108
   Access .................................................................................. 108
   Events List tab .................................................................... 110
   Printing tab ........................................................................ 115
   Synchronization tab ............................................................ 120
4. USE ................................................................................................................................. 120
   Layout of an Events view .................................................... 120
   Sorting events ..................................................................... 121
   Printing an Events view ...................................................... 121
   Favorite display ................................................................. 121

XII. Gantt Events View ......................................................................................................... 122
1. DEFINITION ..................................................................................................................... 122
2. CONFIGURATION ............................................................................................................. 122
   Creating a view ................................................................. 122
   Modifying a view ............................................................. 123
   Deleting a view ................................................................. 124
3. DISPLAY SETTINGS ........................................................................................................... 125
   Access .................................................................................. 125
   Events List tab .................................................................... 127
   Planner tab .......................................................................... 130
   Events tab ........................................................................... 134
XIII. Kanban Events View ........................................................................................................ 151
  1. DEFINITION .................................................................................................................. 151
  2. DISPLAY SETTINGS ...................................................................................................... 151
     Access .......................................................................................................................... 151
     Events List tab ............................................................................................................. 151
     Printing tab .................................................................................................................. 157
     Synchronization tab ..................................................................................................... 162

XIV. Events Map view ........................................................................................................ 163
  1. DEFINITION .................................................................................................................. 163
  2. CONFIGURATION .......................................................................................................... 163
     Creating a view ............................................................................................................ 163
     Modifying a view ......................................................................................................... 164
     Deleting a view ............................................................................................................ 165
  3. DISPLAY SETTINGS ...................................................................................................... 166
     Access .......................................................................................................................... 166
     Map tab ........................................................................................................................ 167
  4. USE .............................................................................................................................. 168
     Layout of an Events Map view .................................................................................... 168
     Filtering displayed events .......................................................................................... 168
     Printing an Events Map view ...................................................................................... 168
     Favorite display .......................................................................................................... 169

XV. Events Report View ..................................................................................................... 170
  1. DEFINITION .................................................................................................................. 170
  2. CONFIGURATION .......................................................................................................... 170
     Functional prerequisite ............................................................................................... 170
     Creating a view ............................................................................................................ 170
     Modifying a view ......................................................................................................... 171
     Deleting a view ............................................................................................................ 172
  3. DISPLAY SETTINGS ...................................................................................................... 173
     Access .......................................................................................................................... 173
     Events Report tab ........................................................................................................ 174
     Printing tab .................................................................................................................. 180
  4. USE .............................................................................................................................. 183
     Layout of an Events Report view .................................................................................. 183
     Display type of an Events Report view ...................................................................... 183
     Sorting the report rows .............................................................................................. 184
     Printing an Events Report view .................................................................................. 184
     Favorite display .......................................................................................................... 185

XVI. Favorite display .......................................................................................................... 186
  1. DEFINITION .................................................................................................................. 186
## Layout and display

### XVII. Resources Editor
1. **Definition** ............................................. 191
2. **Configuration** ........................................ 191
   - Default Template .................................. 191
   - Creating a Resource Editor .................... 193
   - Modifying a Resource Editor ................. 204
   - Deleting a Resource Editor .................. 204
   - Duplicating a Resource Editor ............. 205
3. **Use** .................................................. 205
   - Double-click on a resource .................... 205
   - Right-click on a resource ...................... 205
   - Heading tooltips .................................. 205
   - Printing .............................................. 206

### XVIII. Event Editor
1. **Definition** ............................................. 207
2. **Configuration** ........................................ 207
   - Default Template .................................. 207
   - Creating an event editor ....................... 208
   - Modifying an event editor ..................... 219
   - Deleting an event editor ..................... 219
   - Duplicating an event editor ............... 220
3. **Use** .................................................. 220
   - Assigning to a creation rule .................. 220
   - Opening the editor ............................... 220
   - Printing an editor ............................... 220

### XIX. Tooltip
1. **Definition** ............................................. 222
2. **Events tooltip** ..................................... 222
3. **Link information popup** ..................... 222
4. **Data tooltip for workloads** .................. 222
5. **Resource rows tooltip** ....................... 223
   - Headings tooltip .................................. 223
   - VALUES TOOLTIP ................................. 223
   - TOOLTIP FOR RESOURCE ROW HEADERS .. 223

### XX. Time scale
1. **Definition** ............................................. 225
2. **Schedule View** .................................... 225
3. **Diary View** ......................................... 225
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>4. GANTT EVENTS VIEW</td>
<td>226</td>
</tr>
<tr>
<td>5. USE</td>
<td>226</td>
</tr>
<tr>
<td>5. USE</td>
<td>226</td>
</tr>
<tr>
<td>Viewing the time scale</td>
<td>226</td>
</tr>
<tr>
<td>Modifying the time scale</td>
<td>227</td>
</tr>
<tr>
<td>XXI. Color map</td>
<td>229</td>
</tr>
<tr>
<td>1. DEFINITION</td>
<td>229</td>
</tr>
<tr>
<td>2. USE</td>
<td>229</td>
</tr>
<tr>
<td>Quick map</td>
<td>229</td>
</tr>
<tr>
<td>Color wheel</td>
<td>230</td>
</tr>
<tr>
<td>Color map</td>
<td>231</td>
</tr>
<tr>
<td>3. LINKED CONCEPTS</td>
<td>231</td>
</tr>
<tr>
<td>XXII. Highlighting</td>
<td>232</td>
</tr>
<tr>
<td>1. DEFINITION</td>
<td>232</td>
</tr>
<tr>
<td>2. USE</td>
<td>232</td>
</tr>
</tbody>
</table>
Chapter I. Main Window

1. DEFINITION

VISUAL PLANNING’s Main Window allows the user to access all of the functions provided by the tool, based on user access rights.

It looks like this:

2. LIST OF WINDOW ELEMENTS

Quick Access Bar

The Quick Access Bar is at the top of the screen to the left.

It provides access to different frequently used appearance and functioning functions.

Menu Bar

The Menu Bar is visible in the Main Window.
It is horizontal and comprises sub-menus containing blocks.

Visibility of the blocks depends on the previously selected element and the user rights. These blocks disappear or are grayed when the user is no longer allowed to use them. The block elements are grayed when they do not correspond to the current type of use.

See Menu Bar

Windows

The windows that can be moved and manipulated in the planner are as follows:

1. Configurable views of the resources and events in several forms,
2. The General Settings management window.

The layout of these windows can be configured to a considerable degree. (See Layout of views)

There are other windows in the tool but they are only visible following a user action:

- information, warning and restriction messages,
- windows showing properties of events, resources and links,
- tooltips.

Status bar

This bar at the bottom of the window indicates:

- the name of the selected view and the filters applied to the view,
- the name of the started favorite display,
- the list of installed additional modules,
- the name of the user group or groups,
- the number of users logged into the planner as well as their logins,
- the current date and time.

View

This is the name of the selected view as well as the name of the resource and/or event filters applied to the view.

Favorite display

This is the name of the favorite display the user is in.
Modules

If you position the mouse over the module icon, a tooltip is displayed containing the list of installed additional modules.

Groups

If you position the mouse over the group icon, a tooltip is displayed containing the name of the group or groups the user belongs to on the planner.

An orange padlock shows that group permissions apply.

If the logged in user is the “admin” login or if the user is the planner administrator, the orange padlock is not shown. The permissions do not apply.

Users

If you position the mouse over the user icon, a tooltip is displayed containing the list of logged in users.

You can access a more precise list of users logged into the planner by double-clicking on the blue icon for logged in users.
This window contains the list of all logged in users and their characteristics.

In this window, it is possible to send an e-mail or create a VPWhatsUP discussion with a user from the list.

**Pop-up menu**

Right-click on any element in the Main Window to display menus. These menus provide quick access to the actions permitted by this object.

See [Pop-up menu](#)
Chapter II. Menu Bar

1. DEFINITION

The **Menu Bar** is visible in the Main Window.

It is horizontal and comprises sub-menus containing blocks.

Visibility of the blocks depends on the previously selected element and the user rights.

These blocks disappear or are grayed when the user is no longer allowed to use them.

The block elements are grayed when they do not correspond to the current type of use.

2. PLANNER MENU

<table>
<thead>
<tr>
<th>Planning</th>
<th>Ouvrir</th>
<th>Ajouter un planning</th>
<th>Impression</th>
<th>Mise en page</th>
<th>Exporter des ressources</th>
<th>Exporter des événements</th>
<th>Importer des ressources</th>
<th>Importer des événements</th>
<th>Quitter</th>
</tr>
</thead>
</table>

**Planner block**

- Open (see [Open an existing planner](#)),
- Add a planner (see [Planner templates](#)),
- Delete the planner: only in VISUAL PLANNING **ONE**,

**Printing block**
Layout and display

- Print,
- PDF,
- Preview,
- Page layout.

See Printing

Export block

- Export Resources,
- Export Events,
- Export an Events Report,
- Export the planner: only in VISUAL PLANNING ONE,
  - Into a file,
  - As a template.

Import block

- Import Resources,
- Import Events,
- Import the planner: only in VISUAL PLANNING ONE,
  - ONE version: imports the planner,
  - ENTERPRISE version: see Admin Center. (see Admin Center).
Exit block

Closes the application (server version: only the client).

3. SETTINGS MENU

Windows block

Global Settings

Configuration block

This block is also used to manage VISUAL PLANNING modules and Global Settings.

4. EDIT MENU

The Edit menu changes depending on which entities and views you select.
General block

These are data manipulation functionalities (Resources, Events, Links).

- Modify,
- Duplicate,
- Delete.

Events block

- Cut,
- Copy,
- Repeat:
  - Horizontally,
  - Vertically,
  - On selection.
- Shift,
- Assign Resource,
- Achievement:
  - Auto,
  - 0%,
  - 25%,
  - 50%,
  - 75%,
  - 100%.

See Event
5. DISPLAY MENU

The Display menu changes depending on which entities and views you select.

Add a resource.
Configuration block

See View

Favorite Displays block

- Create a new favorite display,
- Save as,
- Delete favorite display.

See Favorite display

Predefined views block

- Select an existing view,
- Create a view,
- Save the selected view,
- Deleted the selected view,
- Close all views.

See View

Rows block

This block is visible when resources are selected in a Schedule view, Events view or Gantt Events view.
Choose the mode:
- List,
- Tree.

Sort by a heading

**Mode block**

This block is visible when items are selected in a Resources view.

Choose to view the resources in the form of:
- Icon,
- List,
- Details,
- Table.

**Resources block**

This block is visible when items are selected in a Resources view.

Sort by a heading,
Group by a heading,
Choose to view the resources with their:
- Icons,
- Color.
Choose the alignment:
- Vertical,
- Horizontal.

**Planner block**

This block is visible when items are selected in a Schedule view or Gantt Events view.

- Modify the time scale,
- Modify scrolling of the planner,
- Split the planner vertically
- Display the night hours (hours outside the display limits defined in the Schedule view),
- View non working days,
- Display week numbers,
- View links between events,
- Display/hide workloads,
- Modify the workload display mode.

**Diary block**

This block is visible when items are selected in a Diary view.

- Modify the diary display mode,
- Modify the time scale: only enabled if the mode is not “Month”,
- View the night hours (hours outside the display limits defined in the Diary view): only enabled if the mode is not “Month”.

**Events Reports block**

This block is displayed when an Events Report view is selected.
Select the Events Report to display,
Choose the type of display,
Choose the period to display (if allowed by the events report configuration).

6. FILTERS MENU

**Dimension Filters block**

The filters available here those corresponding to the dimension used to build the view.

- View all,
- Modify and access the ‘Dimension’ Filters,
- Display the resources of the ‘Dimension’ that has at least one visible over a period,
- Filter the headings of the ‘Dimension’ where the Automatic filter option has been checked.

**Events Filters block**

- View all,
- Modify and access the Events Filters,
■ Modify and access the Filters for the other dimensions.

**Free Periods block**

This block is visible when items are selected in a Resources view.

■ Find a common Free Period,
■ Find the ‘Dimensions’ that have a common free period.

See [Free Period](#)
Chapter III. Quick Access Bar

1. DEFINITION

The Quick Access Bar is at the top of the screen.

It provides access to different frequently used appearance and functioning functions.

2. LIST OF FUNCTIONS

This menu gives access to the functionalities below.

Favorite display

This button provides access in a single click to all the favorite displays the user is entitled to see.

Refresh

This button is used to refresh the display according to the various modifications made by other users.

This time limit can be:

- 1 minute,
- 2 minutes,
- 5 minutes,
- 10 minutes,
- 15 minutes,
- 30 minutes,
- 1 hour.

Undo / Redo
These buttons are used to undo and redo modifications made by the user during a VISUAL PLANNING session.

Language

You can choose the language VISUAL PLANNING uses on the client workstation.

The choices are:

- Default
- Français,
- English-US,
- English-UK,
- Deutsch,
- Español,
- Italiano.

You must restart VISUAL PLANNING for the change to take effect.

Change password

Use this functionality to change the logged in user’s password.

When you select Change password, the following window appears:

![Change password window]

Display VPWhatsUP view

This button displays all the VPWhatsUP discussions that have been created.
Weather

<table>
<thead>
<tr>
<th>Day</th>
<th>Weather</th>
<th>Temperature min/max</th>
<th>Precipitation</th>
</tr>
</thead>
<tbody>
<tr>
<td>vendredi 03</td>
<td>Globalement nuageux</td>
<td>11°C/15°C</td>
<td>20%</td>
</tr>
<tr>
<td>samedi 04</td>
<td>Pluie légère</td>
<td>8°C/13°C</td>
<td>90%</td>
</tr>
<tr>
<td>dimanche 05</td>
<td>Particulièrement ensoleillé</td>
<td>4°C/10°C</td>
<td>90%</td>
</tr>
<tr>
<td>lundi 06</td>
<td>Ensoleillé</td>
<td>3°C/9°C</td>
<td>10%</td>
</tr>
</tbody>
</table>

This is computed according to the client workstation’s local (IP) address.

When the cursor is positioned on the city, it shows 4 consecutive days.

💡 You can modify the city by double-clicking on the displayed city. A window then opens to indicate a new location.
Chapter IV. Duration Bar

1. DEFINITION

A Duration Bar represents an event graphically.

It can be used to show several characteristics of the event and/or its resources.

- a text comprising one or more pieces of information,
- one or more colors,
- an achievement,
- one or more icons,
- a tooltip,
- one or more child events.

2. CONFIGURATION

Display of Duration Bars can be configured in:

- a Schedule View,
- a Diary View,
- or a Gantt Event View.

3. USE

Views

The Duration Bar can be used in:

- the Schedule View,
- the Diary View,
- the Gantt Events View.
Manipulation

- Create,
- Lengthen / Shorten,
- Shift,
- Delete.

Cut the time bar in the Schedule and Gantt Events views

Check the “Display according to calendar” box in the Schedule and Gantt Events views to cut the events’ duration bars:

- according to the hourly resource calendars if the time scale is less than one day,
- according to the daily resource calendars if the time scale is more than one day.

The events will then be displayed cut if they overlap non working periods.

Printing

When printing, the duration bar characteristics are kept in the resulting print-out.
Chapter V. Smart Toolbar

1. DEFINITION

The **Smart Toolbar** is a menu in the VISUAL PLANNING *Main Window* that replaces both:

- the [menu bar](#),
- and the [quick access bar](#).

This horizontal menu bar simplifies use of VISUAL PLANNING since the list of visible buttons is limited to:

- the most important buttons for users,
- buttons the user is allowed to use.

2. ENABLING

To visible and accessible this menu must be enabled.

It is enabled in the [Admin Center](#) as part of [planner management](#).

When the Smart Toolbar is enabled the menu bar and quick access bar are hidden from all users.

3. DESCRIPTION

The Smart Toolbar has the following buttons:

**Open**

To open a planner.

**Refresh**

This button is used to [refresh](#) the display according to the various modifications made by other users.

This time limit can be:
1 minute,
2 minutes,
5 minutes,
10 minutes,
15 minutes,
30 minutes,
1 hour.

**Undo / Redo**

These buttons are used to undo and redo modifications made by the user during a VISUAL PLANNING session.

**Favorite displays**

This button provides access in a single click to all the favorite displays the user is entitled to see.

**Printing**

- Print,
- Preview,
- PDF,
- Page layout.

See [Printing](#)

**Import / Export**

This button is only shown if an import or export context is defined in the planner.
■ Exports resources,
■ Exports events,
■ Imports resources,
■ Imports Events.

Global Settings

Use this button to display the different elements that structure a planner architecture.

This list is limited to the rights and permissions assigned to the logged in user.

See Global Settings

Resource filters

The filters available here are those the logged in user is allowed to see.

■ Filters of the Dimension’s resources,
■ Automatic filters,
■ View all.

Events filters

The filters available here are those the logged in user is allowed to see.

■ Events filters,
■ Resource filters,
Preferences

Language
You can choose the language VISUAL PLANNING uses on the client workstation.

The choices are:

- Default,
- Français,
- English-US,
- English-UK,
- Deutsch,
- Español,
- Italiano.

You must restart VISUAL PLANNING for the change to take effect.

Password
Use this functionality to change the logged in user’s password.

When you select Change password, the following window appears:

![Change password dialog box](image)

VPWhatsUp
This button displays all the VPWhatsUP discussions that have been created.
Help

Use this menu to access the help options in VISUAL PLANNING:

- Visual Planning help,
- Online support,
- About Visual Planning,
- Give your opinion.

Weather

This is computed according to the client workstation’s local (IP) address.

When the cursor is positioned on the city, it shows 4 consecutive days.

You can modify the city by double-clicking on the displayed city. A window then opens to indicate a new location.
Chapter VI. View

1. DEFINITION

A view represents VISUAL PLANNING data.

There are eight types of view:

- The Schedule View enables you to view the resources of a dimension and their events on a horizontal schedule,
- The Diary View enables you to view the events from one or more resources in the form of a diary,
- The Events View enables you to view the events in the form of a list,
- The Gantt Events View enables you to view the events in the form of a Gantt diagram,
- The Kanban Events View enables you to view the events in Kanban mode,
- The Events Map View enables you to view the events on a map,
- The Resources View gives a visual representation of the resources. It is used in particular to store resources to be assigned on the planner.
- The Events Report View enables you to view the result of an Events Report.

2. CHARACTERISTICS

Depending on its type, a view stores:

- The row height (in the case of the Schedule View),
- The width of the resource columns (in the case of the Schedule View),
- The width of the time scale columns,
- The time scale (in the case of the Schedule View and the Diary View),
- The time bar labels and the tooltips (in the case of the Schedule View),
- Different options for the Schedule View (week-end, non working days, night hours, etc.),
- The filters applied.
- …

3. CONFIGURATION

Creating a view

To create a view, you must go either to General Settings, or to the Display menu.

The General settings are only accessible for the planner administrator.

There are several entry points:
- Either in General Settings, right-click on a dimension > Create View > Choose the type of view,
- Or in General Settings, right-click on Predefined views > Create View > Choose the type of view,
- Or in the Display menu > Predefined views block > Create View > Choose the type of view.

Specify the subsequent characteristics, then click on the Validate button to create the view.

**Dimension**

Select the dimension that will guide the view.

**Name**

Give the view a name. This is mandatory.

**Description**

Give the view a description. The description is optional.

**Modifying a view**

To modify a view, simply change one or more of its display settings.

Then you must save these modifications. There are several entry points:

**Situation 1: Predefined views block**

This menu is accessible for all users who have the right to modify favorite displays.
Go to the Display menu > Predefined views block > Choose the view to modify.

You can then modify the view’s name and description.

Now click on:

- **OK** to save the modifications,
- Or **Cancel** to cancel the modifications.

**General Settings**

The General settings are only accessible for the planner administrator.

Go to the General Settings menu > Predefined views > Select the view.

You can then modify the view’s name and description.

Now click on:

- **Validate** to save the modifications,
- Or **Redo** to cancel the modifications.

**Deleting a view**

Deleting a predefined view is an important configuration task and should not be performed without careful consideration.

**Situation 1: Predefined views block**

This menu is accessible for all users who have the right to modify favorite displays.

The view must be selected before it is deleted.

Go to the Display menu > Predefined views block > Choose the view to delete.

The following message appears:
Now click on:

- Yes to delete the view,
- **No** to cancel deletion.

### General Settings

The General settings are only accessible for the planner administrator.

Go to the **General Settings menu > Predefined views > Choose the view to delete**.

The following message appears:

```
Now click on:

- Yes to delete the view,
- **No** to cancel deletion.
```

4. **USE**

#### Layout of views

Views are an integral part of the dashboards that we call **Favorite Display**.

You can position them as you wish within the tool’s **Main Window**.

See [Layout of views](#).

#### Title bar and applied filters

The view title bar only contains the name of the view.

To see the applied filters and the displayed period, if necessary click on the view. This information is located at the bottom of the view.

#### Printing a view

You can print a view with all its characteristics.
See [Printing a view](#)

## Synchronizing views

You can synchronize several views using these criteria:

- filter,
- date,
- scale.

Each view is synchronized by configuring the characteristics for which it will depend on other views.

Specify synchronization of the “slave” view.

This synchronization must be configured on both views, in order for it work.

**Example:**

Define that a view A is synchronized on filters means:

If you modify the filters applied to the other visible view B, the filters will be applied to the first view A.
Chapter VII. Layout of views

1. DEFINITION

The layout of the views determines how all the data in the favorite display is organized and arranged.

The views can be placed:

- Left of the display,
- Right of the display,
- At the bottom of the display,
- In the middle of the display,
- In the form of tabs, superimposed in the favorite display.

You can “pin” views using the “drawing pin”.

2. USE

Shifting a view

- Click on the view title bar,
- Drag the mouse pointer into the display. A grayed zone gives a preview of the view’s position. The size adapts automatically,
- Release the mouse button.

Superimposing views

- Drag the view to the middle of another view. A grayed zone gives a preview of the view’s position with a tab,
- Release the mouse button,
- The size adapts automatically.

Pinning a view

This action is available for certain views.

Click on this button to hide the display view, but without closing it.
It is still present, minimized either at the bottom of the display, or to the right depending on the view’s initial position.

This enables you to later display the view again by moving the mouse over the minimized view.
Chapter VIII. Resources View

1. DEFINITION

A Resources View is a view enabling you to view a set of resources with the same dimension.

This type of view is useful to collect a “Basket” of resources in order to create events in another view.

The Resources View has several display modes:

- Details mode,
- Icon mode,
- List mode,
- Table mode.

2. CONFIGURATION

Creating a view

To create a view, you must go either to General Settings, or to the Display menu.

The General settings are only accessible for the planner administrator.

There are several entry points:

- Either in General Settings, right-click on a dimension > Create View > Choose the type of view,
- Or in General Settings, right-click on Predefined views > Create View > Choose the type of view,
- Or in the Display menu > Predefined views block > Create View > Choose the type of view.
Specify the subsequent characteristics, then click on the Validate button to create the view.

**Dimension**

Select the dimension that will guide the view.

**Name**

Give the view a name. This is mandatory.

**Description**

Give the view a description. The description is optional.

**Modifying a view**

To modify a view, simply change one or more of its display settings. Then you must save these modifications. There are several entry points:

**Situation 1: Predefined views block**

This menu is accessible for all users who have the right to modify favorite displays.

Go to the Display menu > Predefined views block > Choose the view to modify.

You can then modify the view’s name and description.
Now click on:

- **OK** to save the modifications,
- Or **Cancel** to cancel the modifications.

**General Settings**

The General settings are only accessible for the planner administrator.

Go to the General Settings menu > Predefined views > Select the view. You can then modify the view’s name and description.

Now click on:

- **Validate** to save the modifications,
- Or **Redo** to cancel the modifications.

**Deleting a view**

 Deleting a predefined view is an important configuration task and should not be performed without careful consideration.

**Situation 1: Predefined views block**

This menu is accessible for all users who have the right to modify favorite displays.

The view must be selected before it is deleted.

Go to the Display menu > Predefined views block > Choose the view to delete. The following message appears:

Now click on:

- Yes to delete the view,
No to cancel deletion.

**General Settings**

The General settings are only accessible for the planner administrator.

Go to the General Settings menu > Predefined views > Choose the view to delete.

The following message appears:

![Message](image)

Now click on:

- Yes to delete the view,
- No to cancel deletion.

### 3. DISPLAY SETTINGS

**Access**

The display settings are displayed automatically when a view is created.

There are several ways to access a view’s Display Settings:

- Go to General settings > Click on Predefined views > Choose the view > Display settings, or;
- Go to Display > Click on Display Settings, or;
- Click on the button in the view header.

In all cases, a window appears.
Now modify the settings and click on the **Validate** button

The window has three tabs:

- **Resources tab**,
- **Printing tab**,
- **Synchronization tab**.

**Resources tab**

Use this tab to define the view display format.

**Display mode**

There are four display modes for the Resources View:

- **Details,**
■ Icon,
■ List,
■ Table.

Alignment

Choose to align the resources:

■ vertically,
■ or horizontally.

Table mode does not have this characteristic.

Sort the default editor

Check this box to sort a resource’s editor in the order chosen in the Description headings field, then in order of the general settings, for headings which are not visible in the view.

If the box is not checked, the headings are sorted in the order of headings defined in the configuration of the dimension in the General settings.

Font

Right-click on the right-hand button to open the font definition window:

You can choose:

■ a font,
■ a style (bold, italics, etc.),
■ a character size.
**Ascending sort**

Check this box to sort the resources in alphabetical order.

If it is not checked, the resources are sorted in reverse alphabetical order.

**Sort by**

You must choose one of the headings from the dimension linked to this Resources View.

In table mode, the symbol is displayed on the header of the heading you have chosen for sorting.

**Main heading**

The main heading is the heading making it possible to identify the resource, when a label is visible.

Table mode does not have this characteristic.

**Group by**

It may be useful to group resources according to a criterion.

You choose this criterion from one of the dimension’s headings.

**All headings**

Check this box to automatically display the new headings created in the Resources View in table mode.

- **Box not checked**: new headings are not displayed automatically,
- **Box checked**: new headings are displayed automatically.

**Description headings**

Description headings are useful in Details mode and Table mode.

Details mode enables you to view several headings in the form of a description of the resource.

These headings can be chosen from:

- all the dimension’s headings,
- headings of dependent resources,
- resource settings (hourly calendar, daily calendar and the creation rule),
- the resource’s history attributes,
- forum attributes (Last Post Date and Last Post User).
Use this button ✏️ to open the following window:

In the left-hand part choose the headings to display by dragging them from left to right using the arrows.

You can also sort appearance of data in the time bar using the sorting arrows.

Click on OK to confirm your choice.

**Separator**

If there are several description headings, it is useful to choose one or more characters to separate them.

Table mode does not have this characteristic.

**Filter of authorized 'Dimensions'**

Select the dimension filters that will be available for use in this view.

**Background color**

You can view resources with a background color.
This color can be:

- the color of the Resource itself,
- the color of a dependent resource, in the case of a resource heading,
- or the color of a heading with Threshold (control columns or operation headings),
- or else an events values heading with a resource as its value.

Only persistent headings can be defined as a background color.

**Icon size**

Choose the size of icons, from 16 to 64 pixels.

**Display totals**

In Table mode, this checkbox enables you to display the total values of the numeric, control column and operation headings.

Only Table mode has this characteristic.

**Visual**

Use this list to choose the display mode of the resource symbol. Choose Icon or Color.

Table mode does not have this characteristic.

**Display icons**

In Table mode, this checkbox is used to display the resource icons.

Only Table mode has this characteristic.

**Display row numbers**

In Table mode, this checkbox is used to display the resource row numbers.
Only Table mode has this characteristic.

**Printing tab**

Use this tab to define the view printing settings. (See [Printing a view](#))

**Adjustment**

To adjust printing to the page size.

The possible adjustments are:

- None,
- To the page,
- To the width,
To the height.

The row height when printing on several pages is adjusted to the maximum height encountered during the entire printed period.

Only Table mode can be adjusted.

**Footer**

To define the printing footer:

The following buttons enable you to define automatic information:

- : Page number,
- : Number of pages,
- : Print date,
- : Print time,
- : Schedule name,
- : View name,
- : Name of user,
- : Name of permission group.

You can also type in a specific text directly in the relevant zone.

**Header**

To define the printing header:
The following buttons enable you to define information automatically:

- ![Page number](image)
- ![Number of pages](image)
- ![Print date](image)
- ![Print time](image)
- ![Schedule name](image)
- ![View name](image)
- ![Name of user](image)
- ![Name of permission group](image)

You can also type in a specific text directly in the relevant zone.

**Page layout**

The following window appears, where you can define the default **page layout** settings for the selected view:
You must specify the page layout characteristics in this window.
You can save this page layout definition in a favorite display.
You must then click on OK to validate the page layout.

**Show logo**
Check this box to show the logo top left in the printing output.

**Select logo**
The logo is an image file that can be displayed in the printing output.
This image is unique for the entire planner.
Click on [...] to display the following window:
You must then look through the directories to select an image file, and click on the **Open** button.
Synchronization tab

Synchronization of a view consists in defining the characteristics that will be dependent on the other views.

The possibilities are as follows:

**Resource filter**

You can synchronize the view’s resources filter with the filters of the other views.

**4. USE**

**Tree mode**

This characteristic only exists in Table mode.
As for the **Schedule View**, the Resources View displays the resources in the form of a tree.

To do this, go to **Display menu > Resource block > Tree mode**

This mode therefore displays resources in the form of a tree:

![Tree mode](image)

The display of nodes makes it possible to group several resources which have the same value.

By default the number of levels in the tree is 2, when this mode is enabled.

You can increase or reduce the number of levels using these buttons, located below the view to the left.

In the case of a numeric, control column or operation heading, the value of the node for this heading is:

- **integer or decimal** display format: the node is equal to the total of its resources’ values,
- **percentage** display format: the node is equal to the mean of its resources’ values.

**Layout of a Resources View**

The Resources view is laid out in the Main window like the other views.

**Sorting resources**

Like for the other views that have a table mode, you can sort the resources using the columns visible in this table mode.
Printing a Resources View

Like the other views, you can print:

- the Resources view itself,
- the resources that make up the view.

See Printing

Favorite display

Like the other views, a Resources view can be saved in a favorite display.
Chapter IX. Schedule View

1. DEFINITION

The Schedule View represents the planning of a set of resources belonging to a dimension on a horizontal planner grid.

2. CONFIGURATION

Creating a view

To create a view, you must go either to General Settings, or to the Display menu. The General settings are only accessible for the planner administrator.

There are several entry points:

- Either in General Settings, right-click on a dimension > Create View > Choose the type of view,
- Or in General Settings, right-click on Predefined views > Create View > Choose the type of view,
- Or in the Display menu > Predefined views block > Create View > Choose the type of view.
Specify the subsequent characteristics, then click on the Validate button to create the view.

**Dimension**
Select the dimension that will guide the view.

**Name**
Give the view a name. This is mandatory.

**Description**
Give the view a description. The description is optional.

**Modifying a view**
To modify a view, simply change one or more of its display settings.
Then you must save these modifications. There are several entry points:

**Situation 1: Predefined views block**
This menu is accessible for all users who have the right to modify favorite displays.

Go to the **Display menu > Predefined views block > Choose the view to modify**.
You can then modify the view’s name and description.
Now click on:
- OK to save the modifications,
- Or Cancel to cancel the modifications.

**General Settings**
The General settings are only accessible for the planner administrator.

Go to the **General Settings menu > Predefined views > Select the view**. You can then modify the view’s name and description.

Now click on:
- Validate to save the modifications,
- Or Redo to cancel the modifications.

**Deleting a view**
Deleting a predefined view is an important configuration task and should not be performed without careful consideration.

**Situation 1: Predefined views block**
This menu is accessible for all users who have the right to modify favorite displays. The view must be selected before it is deleted.

Go to the **Display menu > Predefined views block > Choose the view to delete**. The following message appears:

```
Question

Voulez-vous supprimer la vue prédéfinie ?
'Absences'

Attention! Cette vue ne sera plus visible dans les favoris d'affichage qui l'utilisent.
```

Now click on:
- Yes to delete the view,
- No to cancel deletion.

**General Settings**
The General settings are only accessible for the planner administrator.
Go to the General Settings menu > Predefined views > Choose the view to delete.

The following message appears:

Now click on:

- Yes to delete the view,
- No to cancel deletion.

3. DISPLAY SETTINGS

Access

The display settings are displayed automatically when a view is created.

There are several ways to access a view’s Display Settings:

- Go to General settings > Click on Predefined views > Choose the view > Display settings, or;
- Go to **Display > Click on Display Settings**, or;
- Click on the button in the view header.

In all cases, a window appears.

Now modify the settings and click on the **Validate** button.

The window has six tabs:
- **Events tab**,  
- **Planner tab**,  
- **Resource rows tab**,  
- **Workloads tab**,  
- **Printing tab**,  
- **Synchronization tab**.

### Events tab

This tab is for configuration of the *time bars*.

#### Automatic line return

Check this box to force a line return in time bar texts depending on their widths.

#### Fixed height

Check this box to set the same height as the row for all planner events.

### Font

**Right-click on the right-hand button** to open the font definition window:

You can choose:
- a font,
- a style (bold, italics, etc.),
- a character size.
**Time bars label**

You can choose one or more headings to view for events or event attributes.

Use this button to open the following window:

![Image](image_url)

To add a label, select the label in the left-hand part, then drag it to the right-hand part using the arrows.

You can also sort appearance of data in the time bar using the **sorting** arrows.

**Display according to calendar**

Check this box to cut the event time bars:

- according to the hourly resource calendars if the time scale is less than one day,
- according to the daily resource calendars if the time scale is more than one day.

The events will then be displayed cut if they overlap non working periods.

**On one row**

Check this box to put
■ all the labels on the same row.
■ Otherwise there will be one label on each row.

Separator
If display of the labels is on one row, it is necessary to define one or more characters to separate the labels.

Display titles
Check this box to display the label names visible on the time bar.

Alignment
You can choose the position of the labels in relation to the time bar.
The possible choices are as follows:
■ Left,
■ Right,
■ Center,
■ External. In this last case, the labels are visible outside the time bar, to the right.

Border color dimension
This list enables you to choose the dimension whose resources color will be used as the time bar border color.

Use this button to edit the chosen dimension and modify its default color.

Border thickness
You can specify the thickness of this colored border by modifying the numeric value of this thickness.

Background color dimensions
The time bar background color can be:

- none,
- one color if a single dimension is chosen to show the color,
- or multi-colored if several dimensions are chosen to show the color.

Use this button to open the following window:

In this window you can simply drag them from left to right using the arrows:

You can also sort the order of appearance of dimension colors in the time bar using the sorting arrows:

Display the progress bar

You must check this box to display the state of progress on the time bar.

Progress color

You can choose the progress bar color by left-clicking on the color.
The color map then opens.

**Bar position**

This choice list enables you to define the position of the progress bar on the time bar.

This position can be:

- High,
- Center,
- Low.

**Urgent color**

The urgent color indicates the event’s status is urgent.

It is visible

- as the progress bar color,
- or the border color.

You can choose the urgent color by **left-clicking on the color**.

The color map then opens.

---

This is only necessary if **achievement** is manual. In automatic achievement mode the event cannot be urgent.

---

**Linked event filter**

You can show the linked events of dependent dimensions.

Choose an **event filter** to select the events to show from the dimensions chosen on the **resource headings** from the Schedule View’s dimension.

The following options are available:

- All,
- Customize the filter,
- Select a public events filter,
- Select a private events filter.

**Display extra events**

To show linked events, you must choose the resource headings that belong to the active Schedule View.
**Always visible**

Check this box to make icons visible even if the time bar is narrower than the icon.

**Aligning the icon**

You can display one or more icons on the time bar.

These icons can be aligned:

- to the **left**,  
- or the **right** of the time bar.

**Icon Dimensions**

You can choose one or more dimensions to show the event icons.

Use this button to open the following window:

Simply *drag them from left to right* using the arrows:

You can also sort the order of appearance of dimension icons in the time bar using the sorting arrows.
Icon size

Choose the size of icons. from 16 to 64 pixels.

Tooltips like time bars

You can display different information in the time bars and the tooltips.

If you uncheck this box, the information displayed in the tooltip can be different from the information shown in the time bar.

Tooltip labels

If the previous box is not checked, you can modify the tooltip labels.

Use this button to open the following window:

To add a label, select the label in the left-hand part, then drag it to the right-hand part using the arrows.

You can also sort appearance of data in the time bar using the sorting arrows.
Sort in ascending order
Check this box to sort the resource’s events in ascending alphanumerical order.

Labels for sorting
You can sort events planned on a resource according to one or more selected labels.

Allowed Event filters
The list of filters available in the Schedule view can be shortened by choosing from the existing filters.

Planner tab
This tab is for configuration of the planner grid.
### Daily calendar

Choose one of the [daily calendars](#) to be seen as the background color for the planner grid.

This calendar is not necessarily from the view’s resources.
**Hourly calendar**

Choose one of the [hourly calendars](#) to be seen as the background color for the planner grid.

*This calendar is not necessarily from the view’s resources.*

---

**Column width**

Enter a numeric value corresponding to the width in pixels of each column in the planner grid.

**Font**

Choose the font for the view header elements.

*Click on the [...] button to open the font definition window:*

![Font selection dialog](#)

You can choose:

- a font,
- a style (bold, italics, etc.),
- a character size.

**Set to the current date**

Check this box to set the planner to the current date, the first time the view is started.
Scale
Select the view’s time scale.

Scroll
You can define the view scrolling method when using scroll arrows.
The possibilities are:

- Continuous: the planner scrolls like a continuous, endless document,
- Day: the planner can only be viewed day by day. The view always represents a single entire day.
- Week: same as Day. The view always represents a single entire week.
- Month: same as Day. The view always represents a single entire month.
- Year: same as Day. The view represents a single entire year.

Display hourly calendars
Check this box to display hourly resource calendars.

Non working days
Check this box to display days whose period type is non working.

Night hours
Check this box to display night hours.
These night hours are determined by the start and end times explained below.

Vertical grid
Check this box to show the vertical grid on the planner.

Display weeks
Check this box to display the week numbers next to the date on the planner.
This option is only necessary when the time scale is:

- Day,
- 1/2 Day,
- 1/3 Day,
- or 1/4 Day.

Start time
Each day can be limited by a start time and an end time.
These times are the same for every day in the view, regardless of the time scale.
Specify the start time for the days.
This start time is only necessary when the **night hours** option is disabled.
This start time is not linked to the hourly calendars.

**End time**
Each day can be limited by a start time and an end time.
These times are the same for every day in the view, regardless of the time scale.
Specify the end time for the days.
This end time is only necessary when the **night hours** option is disabled.
This end time is not linked to the hourly calendars.

**Period**
Each Schedule view is limited by a start date and an end date.
Choose the **Time Period** that defines the schedule view’s left-hand and right-hand limits.
They can be fixed or variable delimiters, depending on the current date.
No event outside this period can be visible in the view.

**Background color**
You can choose the view’s background color.
This color is for days and times where the type of period does not have a color.
This choice also applies to the resources background color if no such color is specified.

**Load all rows**
Check this box when starting the view, to load all events of all rows corresponding to the view filter, even those that are not directly visible on screen.

**Display links**
Check this box to display the **links between events** in the view.

**Only rows with events**
Check this box to only display resources that have at least one event in the displayed period.

---

This option is not available in continuous scrolling mode.
Display short names

Check this box to not display the headers of dimensions to which the headings to display belong.
Sort the default editor

Check this box to sort a resource’s editor in the order chosen in the Description headings field, then in order of the general settings, for headings which are not visible in the view.

If the box is not checked, the headings are sorted in the order of headings defined in the configuration of the dimension in the General settings.

Font

Right-click on the right-hand button to open the font definition window:

You can choose:

- a font,
- a style (bold, italics, etc.),
- a character size.

Ascending sort

Check this box to perform an ascending sort of the heading defined below.

If it is not checked, the resources are sorted in reverse alphabetical order of the heading.

Sort by

Choose the first heading to manage sorting of resources.

All headings

Check this box to display all the resources’ headings.
Headings

If the previous box is unchecked. Choose the headings to display.

These headings can be chosen from:

- all the dimension’s headings,
- headings of dependent resources,
- resource settings (hourly calendar, daily calendar and the creation rule),
- the resource’s history attributes,
- forum attributes (Last Post Date and Last Post User).

Use this button to open the following window:

In the left-hand part choose the headings to display by dragging them from left to right using the arrows.

You can also sort appearance of data in the time bar using the sorting arrows.

Click on OK to confirm your choice.

Background color

You can view resources with a background color.
This color can be:

- the color of the Resource itself,
- the color of a dependent resource, in the case of a resource heading,
- or the color of a heading with Threshold (control columns or operation headings),
- or else an events values heading with a resource as its value.

Only persistent headings can be defined as a background color.

Icon size

Choose the size of icons, from 16 to 64 pixels.

Font

Right-click on the right-hand button to open the font definition window:

You can choose:

- a font,
- a style (bold, italics, etc.),
- a character size.

Display icons

Check this box to define display of resources’ icons, where applicable.
Display row numbers

Check this box to display the row numbers to the left of the resources.

Display totals

Check this box to display an addition row at the bottom of the view. This row performs computations on certain headings:

- total of numeric values,
- mean of values as a percentage.

Filter of authorized ‘Dimensions’

Choose the dimension filters that will be visible and available for use in this view.
Workloads tab

Display total

Check this box to display an additional workload that computes the total of visible workloads.
Display workloads

Check this box to display the workloads selected below in the Schedule view.

Workload

Choose the workload(s) to display in the Schedule view.
Printing tab

Use this tab to define the view printing settings. (See Printing a view)

Number of periods per page

This is the number of periods per page that will be displayed.
**Period by page**

This is the type of period that will be used (day, week, month) to determine the number of periods above.

**Restrict to events**

Check this box to restrict printing to the shortest period containing events.

The first period displayed will be the period containing the first events in the period defined below. The last period will be the period containing the last events in the period defined below.

**Period**

This is the data printing period (this month, this week, this year, customized period, etc.).

**Footer**

To define the printing footer:

The following buttons enable you to define automatic information:

- ![Page number]: Page number,
- ![Number of pages]: Number of pages,
- ![Print date]: Print date,
- ![Print time]: Print time,
- ![Schedule name]: Schedule name,
- ![View name]: View name,
- ![Name of user]: Name of user,
- ![Name of permission group]: Name of permission group.
You can also type in a specific text directly in the relevant zone.

**Header**

To define the printing header:

![Header settings](image)

The following buttons enable you to define information automatically:

- ![Page number](image)
- ![Number of pages](image)
- ![Print date](image)
- ![Print time](image)
- ![Schedule name](image)
- ![View name](image)
- ![Name of user](image)
- ![Name of permission group](image)

You can also type in a specific text directly in the relevant zone.

**Page break on heading**

This enable you to print one page per row, row after row, according to the resources sorting heading.

**Page layout**

The following window appears, where you can define the default **page layout** settings for the selected view:
You must specify the page layout characteristics in this window.

You can save this page layout definition in a favorite display.

You must then click on **OK** to validate the page layout.

**‘Streamer’ mode**

Check this box to place several printing rows on the same page, if the page height permits.

**Show logo**

Check this box to show the logo top left in the printing output.

**Select logo**

The logo is an image file that can be displayed in the printing output.

This image is unique for the entire planner.

Click on [...] to display the following window:
You must then look through the directories to select an image file, and click on the Open button.
Synchronization tab

Synchronization of a view consists in defining the characteristics that will be dependent on the other views.

The possibilities are as follows:
**Date**
Check this box to synchronize the Schedule date with the date in the other views.
The schedule date is the date in the view’s calendar.

**Schedule scale**
Check this box to synchronize the view’s time scale with that of the other views.

**Events filters**
You can synchronize the view’s events filter with the events filters of the other views.

**Resource filter**
You can synchronize the view’s resources filter with the filters of the other views.

### 4. USE

**Tree mode**
The Schedule View displays the resources in the form of a tree.
To do this, go to *Display menu > Row block > Tree mode*

This mode therefore displays resources in the form of a tree:

![Tree mode example](image)

The display of nodes makes it possible to group several resources which have the same value.
By default the number of levels in the tree is 2, when this mode is enabled.

You can increase or reduce the number of levels using these buttons \( - \) \( + \), located below the view to the left.

In the event of disabling and immediate re-enabling, the number of levels is memorized.

In the case of a numeric, control column or operation heading, the value of the node for this heading is:

- **integer or decimal** display format: the node is equal to the total of its resources' values,
- **percentage** display format: the node is equal to the mean of its resources' values.

The **Search** function is also possible in tree mode, see: Search

**Layout of a Schedule view**

The Schedule view is laid out in the Main window like the other views.

**Moving in the Schedule view**

To browse times:
- Use the **calendar**,
- Use the **Left** keyboard key to go back, and the **Right** keyboard key to go forward in times.

To browse resources:
- Use the scroll bar,
- Use the **Up** and **Down** keyboard keys.

**Sorting resources**

Like for the other views that have a table mode, you can sort the resources using the columns visible in the left-hand part of the resources.

**Printing a Schedule view**

Like the other views, you can print the Schedule view.

**Favorite display**

Like the other views, a Schedule view can be saved in a favorite display.
Chapter X. Diary View

1. DEFINITION

The **Diary View** enables you to see the *events* schedule in the form of a diary.

A **Diary View** can show you:

- a day,
- a week,
- a working week, i.e. without the non working days,
- a month.

2. CONFIGURATION

**Creating a view**

To create a view, you must go either to **General Settings**, or to the Display menu.
The General settings are only accessible for the planner administrator. There are several entry points:

- Either in General Settings, right-click on a dimension > Create View > Choose the type of view,
- Or in General Settings, right-click on Predefined views > Create View > Choose the type of view,
- Or in the Display menu > Predefined views block > Create View > Choose the type of view.

Specify the subsequent characteristics, then click on the Validate button to create the view.

**Dimension**

Select the dimension that will guide the view.

**Name**

Give the view a name. This is mandatory.

**Description**

Give the view a description. The description is optional.

**Modifying a view**

To modify a view, simply change one or more of its display settings.

Then you must save these modifications. There are several entry points:
Situation 1: Predefined views block
This menu is accessible for all users who have the right to modify favorite displays.

Go to the Display menu > Predefined views block > Choose the view to modify.
You can then modify the view’s name and description.

Now click on:
- **OK** to save the modifications,
- Or **Cancel** to cancel the modifications.

**General Settings**
The General settings are only accessible for the planner administrator.

Go to the General Settings menu > Predefined views > Select the view.
You can then modify the view’s name and description.

Now click on:
- **Validate** to save the modifications,
- Or **Redo** to cancel the modifications.

**Deleting a view**

Deleting a predefined view is an important configuration task and should not be performed without careful consideration.

Situation 1: Predefined views block
This menu is accessible for all users who have the right to modify favorite displays.

The view must be selected before it is deleted.

Go to the Display menu > Predefined views block > Choose the view to delete.

The following message appears:
Now click on:

- **Yes** to delete the view,
- **No** to cancel deletion.

### General Settings

The General settings are only accessible for the planner administrator.

Go to the *General Settings menu > Predefined views > Choose the view to delete*.

The following message appears:

```
Question

¿Quieres suprimir la vista previamente definida?
'Absences'

¡Atención! Esta vista no será visible para los usuarios de visualización que la utilizan.

Oui  Non
```

Now click on:

- **Yes** to delete the view,
- **No** to cancel deletion.

### 3. DISPLAY SETTINGS

#### Access

The display settings are displayed automatically when a view is created.

There are several ways to access a view’s Display Settings:
■ Go to General settings > Click on Predefined views > Choose the view > Display settings, or;

■ Go to Display > Click on Display Settings, or;
  ■ Click on the button 🔄 in the view header.

In all cases, a window appears.
Now modify the settings and click on the **Validate** button.

The window has four tabs:

- **Diary tab**.
- **Events tab**.
- **Printing tab**.
- **Synchronization tab**.
Diary tab

This tab is for configuration of the diary grid.

Daily calendar

Choose one of the daily calendars to be seen as the background color for the diary grid. This calendar is not necessarily from the view's resources.

Hourly calendar

Choose one of the hourly calendars to be seen as the background color for the diary grid. This calendar is not necessarily from the view's resources.

Font

Choose the font for the view header elements.

Click on the [...] button to open the font definition window:

![Font Selection Window]

You can choose:

- a font,
- a style (bold, italics, etc.),
- a character size.

Display mode

In a Diary View, days are presented horizontally and hours vertically.
There are four display modes for the Diary View:

- **Day**: a column representing a day, with hours along the vertical axis;
- **Working week**: five columns for the working days from Monday to Friday, with hours along the vertical axis;
- **Week**: seven columns for the days from Monday to Sunday, with hours along the vertical axis;
- **Month**: for days from Monday to Sunday, with weeks along the vertical axis.

In a Diary View in Month mode, a maximum of three event bars can be displayed. This is an event overlap.

**Set to the current date**
Check this box to set the view to the current date, each time the favorite display using this view is started.

**Display hourly calendars**
Check this box to display the hourly calendars.

**Non working hours**
Check this box to display hours whose period type is non working.

**Start time**
Define the start time when displaying a day.
This start time is necessary when the Non working hours option is disabled.
This start time is not linked to the hourly calendars.

**End time**
Define the end time when displaying a day.
This end time is necessary when the Non working hours option is disabled.
This end time is not linked to the hourly calendars.

**Period**
Define the display delimiters for the Diary View.

**Filter of authorized ‘Dimensions’**
Choose the ‘Dimension’ filters that will be available and visible in the Diary View.
Background color
Choose the view’s background color.
This color is for days and times where the type of period does not have a color.

Load all rows
Check this box to load all the events.

Only rows with events
Check this box to only display rows that have events.

Events tab
This tab is for configuration of the time bars.
The following settings are taken into account for display of the time bars:

**Font**

**Right-click on the right-hand button** to open the font definition window:
You can choose:

- a font,
- a style (bold, italics, etc.),
- a character size.

**Time bars label**

To access the choice of data to display, **Click on this button** 🖊️ in the **Time bars label** field.

All the VISUAL PLANNING data is present in the window that appears.

Use the pull-down list to filter the type of available entities.
To add a label, select the label in the left-hand part, then drag it to the right-hand part using the arrows.

You can also sort appearance of data in the time bar using the sorting arrows.

In general, if several properties are selected in the display settings, only one label will be displayed.

**Alignment**

You can choose the position of the labels in relation to the time bar.

The possible choices are as follows:

- Left,
- Right,
- Center,
- External.

External alignment is only necessary for daily events or in Month mode.
Border color dimension

This list enables you to choose the dimension whose resources color will be used as the time bar border color.

Use this button to edit the chosen dimension and modify its default color.

Border thickness

You can specify the thickness of this colored border by modifying the numeric value of this thickness.

Background color dimensions

The time bar background color can be:

- one color if a single dimension is chosen to show the color,
- multi-colored if several dimensions are chosen to show the color.

Use this button \[\] to open the following window:
**Display the progress bar**

Check this box to display the state of progress on the time bar.

**Progress color**

You can choose the progress bar color by clicking on this field.

The [color map](#) then opens.

**Urgent color**

The urgent color indicates the event’s status is urgent.

It is visible:

- as the progress bar color,
- or the border color.

This is only necessary if [achievement](#) is manual. In automatic achievement mode the event cannot be urgent.

You can choose the urgent color by clicking on this field.

The color map then opens.

**Linked event filter**

You can show the linked events of dependent dimensions.

Choose an [event filter](#) to select the events to show from the dimensions chosen on the [resource headings](#) from the Diary View’s dimension.
Display extra events

To show linked events, you must choose the resource headings, if any, that belong to the active Diary View.

Always visible

Check this box to make the icon always visible, even if the visible duration of the event is less than the icon height.

Aligning the icon

You can display one or more icons on the time bar.

These icons can be aligned:

- to the left,
- or the right of the time bar.

Icon Dimensions

You can choose one or more dimensions to show the event icons.

Use this button to open the following window:

![Icon Dimensions Window]

Simply drag them from left to right using the arrows:

![Drag Arrows]

Tooltips like time bars

You can display different information in the time bars and the tooltips.
If you **uncheck** this box, the information displayed in the tooltip can be different from the information shown in the time bar.

**Tooltip labels**

If the previous box is not checked, you can therefore modify the tooltip labels.

Use this button 🖌️ to open the following window:

You must then choose in the left-hand window the labels to display in the tooltips by dragging from left to right using the arrows.

You can sort appearance of data in the time bar using the **sorting** arrows.

**Sort in ascending order**

Check this box to sort displayed events in ascending order.
Labels for sorting

You can sort displayed events in alphabetical order according to certain event data. To do so, click on this button 🛠.

The following window opens:

Allowed Event filters

The list of filters available in the Diary view can be shortened by choosing from the existing filters.
Use this tab to define the view printing settings. (See [Printing a view](#))

**Footer**

To define the printing footer:
The following buttons enable you to define automatic information:

- [ ] : Page number,
- [ ] : Number of pages,
- [ ] : Print date,
- [ ] : Print time,
- [ ] : Schedule name,
- [ ] : View name,
- [ ] : Name of user,
- [ ] : Name of permission group.

You can also type in a specific text directly in the relevant zone.

**Header**

To define the printing header:

The following buttons enable you to define information automatically:

- [ ] : Page number,
You can also type in a specific text directly in the relevant zone.

**Page layout**

The following window appears, where you can define the default page layout settings for the selected view:

You must specify the page layout characteristics in this window.

You can save this page layout definition in a favorite display.
You must then click on **OK** to validate the page layout.

**Show logo**

Check this box to show the logo top left in the printing output.

**Select logo**

The logo is an image file that can be displayed in the printing output. This image is unique for the entire planner.

Click on […] to display the following window:

You must then look through the directories to select an image file, and click on the **Open** button.
Synchronization tab

Synchronization of a view consists in defining the characteristics that will be dependent on the other views.

The possibilities are as follows:
Date
Check this box to synchronize the diary date with the date in the other views.
The diary date is the date in the view's calendar.

Events filters
You can synchronize the view’s events filter with the events filters of the other views.

Resource filter
You can synchronize the view’s resources filter with the filters of the other views.

4. USE
Creating a Diary View event
You can create an event in a Diary view.
To do so:
■ Either double-click on the view,
■ Or drag-drop a resource from another view.

If this display mode is not Month, all events created in a Diary View are the hourly type.
This applies even if the event creation rules are defined with a daily type.

Event display mode
Display and configuration of event bars in Diary View is similar to Schedule View. However there are a few differences in the display mode.

Layout of a Diary View
The Diary view is laid out in the Main window like the other views.

Printing a Diary View
Like the other views, you can print the Diary view.

Favorite display
Like the other views, a Diary view can be saved in a favorite display.
You can display a maximum of 3 events.

If there are more than 3 events, you must click on the small green triangle to display all the day’s events.
Chapter XI. Events View

1. DEFINITION

An Events View is a list of the events from one or more resources. It is a vertical list where the events are sorted in chronological or reverse chronological order. This concept is similar to a “task list”.

There are two ways to view this list of events:

- In a resource’s properties: Events tab,
- In a dedicated view: the Events View described here.

2. CONFIGURATION

Creating a view

To create a view, you must go either to General Settings, or to the Display menu.

The General settings are only accessible for the planner administrator.

There are several entry points:

- Either in General Settings, right-click on a dimension > Create View > Choose the type of view,
Or in General Settings, right-click on Predefined views > Create View > Choose the type of view,
Or in the Display menu > Predefined views block > Create View > Choose the type of view.

Specify the subsequent characteristics, then click on the Validate button to create the view.

**Dimension**

Select the dimension that will guide the view.

**Name**

Give the view a name. This is mandatory.

**Description**

Give the view a description. The description is optional.

**Modifying a view**

To modify a view, simply change one or more of its display settings.
Then you must save these modifications. There are several entry points:

**Situation 1: Predefined views block**

This menu is accessible for all users who have the right to modify favorite displays.
Go to the **Display menu > Predefined views block > Choose the view to modify**.

You can then modify the view’s name and description.

Now click on:

- **OK** to save the modifications,
- **Cancel** to cancel the modifications.

**General Settings**

The General settings are only accessible for the planner administrator.

Go to the **General Settings menu > Predefined views > Select the view**.

You can then modify the view’s name and description.

Now click on:

- **Validate** to save the modifications,
- **Redo** to cancel the modifications.

**Deleting a view**

Deleting a predefined view is an important configuration task and should not be performed without careful consideration.

**Situation 1: Predefined views block**

This menu is accessible for all users who have the right to modify favorite displays.

The view must be selected before it is deleted.

Go to the **Display menu > Predefined views block > Choose the view to delete**.

The following message appears:
Now click on:

- Yes to delete the view,
- No to cancel deletion.

**General Settings**

The General settings are only accessible for the planner administrator.

Go to the General Settings menu > Predefined views > Choose the view to delete.

The following message appears:

Now click on:

- Yes to delete the view,
- No to cancel deletion.

---

3. DISPLAY SETTINGS

**Access**

The display settings are displayed automatically when a view is created.

There are several ways to access a view’s Display Settings:

- Go to General settings > Click on Predefined views > Choose the view > Display settings,
- Go to **Display > Click on Display Settings**, 
- Click on the button in the view header.

In all cases, a window appears.
Now modify the settings and click on the **Validate** button.

The window has three tabs:

- **Events List tab**.
- **Printing tab**.
- **Synchronization tab**.

**Events List tab**

**Display mode**

You can view an Events View in the form of:

- Details,
- Table.

| Details mode | Table mode |
Period

You can display events over a period:

- Continuous,
- Day,
- Week,
- Month,
- Year.

Events will then appear according to the chosen period.

Display row numbers

This option is only available in Table mode.

Check this box to display the event row numbers.

Display totals

This option is only available in Table mode.

Check this box to display the totals of the numeric, total column and operation headings.

Auto Format text

This option is only available in Details mode.
Check this box to display the names of VISUAL PLANNING attributes and entities in the Events view.

**Display headers**

This option is only available in *Details* mode.

Check this box to display the names of VISUAL PLANNING entities and attributes.

*Example:* **Event-Start day:** 24/11/2015 or **Start day:** 24/11/2015

**Display short names**

Check this box to display the names of dimensions to which the headings to display belong, or the names of the VISUAL PLANNING entities.

*Example:* **Start Day:** 24/11/2015 or **Name:** MARTIN

**Icon size**

Choose the size of icons. from 16 to 64 pixels.

**Labels**

You can choose one or more headings to view for events or event attributes.

Use this button to open the following window:

To add a label, select the label in the left-hand part, then drag it to the right-hand part using the arrows.
You can also sort appearance of data in the time bar using the sorting arrows.

**Font**

**Right-click on the right-hand button** to open the font definition window:

![Font Definition Window]

You can choose:

- a font,
- a style (bold, italics, etc.),
- a character size.

**Unrestricted HTML text**

This option is only available in *Details* mode if the *Auto Format Text* box is not checked.

Right-clicking brings up an HTML editor.
This makes it possible to create your own visuals for events in the view:

- By entering formatted or unformatted text,
- By inserting images, tables and event attributes.

**Icon Dimensions**

You can choose one or more dimensions to show the event icons.

Use this button ![open button](image) to open the following window:

Simply *drag them from left to right* using the arrows:
Color Dimensions

Each event’s background color can be:

- one color if a single dimension is chosen to show the color,
- multi-colored if several dimensions are chosen to show the color.

If several dimensions are chosen, the colors will only be visible in Details mode.
In Table mode, only the color of the first dimension appears.

Use this button to open the following window:

Allowed Event filters

The list of filters available in the Events view can be shortened by choosing from the existing filters.

Filter of authorized ‘Dimensions’

Select the dimension filters that will be available for use in this view.

Printing tab

Printing of an event view functions in a similar way to the WYSIWYG concept.
Use this tab to define the view printing settings. (See Printing a view)

**Adjustment**

To adjust printing to the page size.

The possible adjustments are:

- None,
- To the page,
- To the width,
- To the height.

The row height when printing on several pages is adjusted to the maximum height encountered during the entire printed period.

**Footer**

To define the printing footer:
The following buttons enable you to define automatic information:

- : Page number,
- : Number of pages,
- : Print date,
- : Print time,
- : Schedule name,
- : View name,
- : Name of user,
- : Name of permission group.

You can also type in a specific text directly in the relevant zone.

**Header**

To define the printing header:

The following buttons enable you to define information automatically:

- : Page number,
- Number of pages,
- Print date,
- Print time,
- Schedule name,
- View name,
- Name of user,
- Name of permission group.

You can also type in a specific text directly in the relevant zone.

**Page layout**

The following window appears, where you can define the default page layout settings for the selected view:

![Page layout settings window](image)

You must specify the page layout characteristics in this window.

You can save this page layout definition in a favorite display.
You must then click on **OK** to validate the page layout.

**Show logo**

Check this box to show the logo top left in the printing output.

**Select logo**

The logo is an image file that can be displayed in the printing output.

This image is unique for the entire planner.

Click on [...] to display the following window:

![Open file window](image)

You must then look through the directories to select an image file, and click on the **Open** button.
Synchronization tab

Synchronization of a view consists in defining the characteristics that will be dependent on the other views.

The possibilities are as follows:

**Events filters**
You can synchronize the view’s events filter with the events filters of the other views.

**Resource filter**
You can synchronize the view’s resources filter with the filters of the other views.

4. USE

**Layout of an Events view**
The Events view is laid out in the Main window like the other views.
Sorting events

Like for the other views that have a table mode, you can sort the events using the columns visible in this table mode.

Printing an Events view

Like the other views, you can print the Events view.

See Printing

Favorite display

Like the other views, an Events view can be saved in a favorite display.
Chapter XII. Gantt Events View

1. DEFINITION

A Gantt Events View enables you to view a list of events from one or more resources in the form of a Gantt diagram.

2. CONFIGURATION

Creating a view

To create a view, you must go either to General Settings, or to the Display menu.

The General settings are only accessible for the planner administrator.

There are several entry points:

- Either in General Settings, right-click on a dimension > Create View > Choose the type of view,
- Or in General Settings, right-click on Predefined views > Create View > Choose the type of view,
- Or in the Display menu > Predefined views block > Create View > Choose the type of view.
Specify the subsequent characteristics, then click on the Validate button to create the view.

**Dimension**
Select the dimension that will guide the view.

**Name**
Give the view a name. This is mandatory.

**Description**
Give the view a description. The description is optional.

**Modifying a view**
To modify a view, simply change one or more of its display settings.
Then you must save these modifications. There are several entry points:

**Situation 1: Predefined views block**
This menu is accessible for all users who have the right to modify favorite displays.

Go to the Display menu > Predefined views block > Choose the view to modify.
You can then modify the view’s name and description.
Now click on:
■ OK to save the modifications,
■ Or Cancel to cancel the modifications.

**General Settings**

The General settings are only accessible for the planner administrator.

Go to the General Settings menu > Predefined views > Select the view

You can then modify the view’s name and description.

Now click on:

■ Validate to save the modifications,
■ Or Redo to cancel the modifications.

**Deleting a view**

Deleting a predefined view is an important configuration task and should not be performed without careful consideration.

**Situation 1: Predefined views block**

This menu is accessible for all users who have the right to modify favorite displays.

The view must be selected before it is deleted.

Go to the Display menu > Predefined views block > Choose the view to delete

The following message appears:

Now click on:

■ Yes to delete the view,
■ No to cancel deletion.

**General Settings**

The General settings are only accessible for the planner administrator.
Go to the General Settings menu > Predefined views > Choose the view to delete.

The following message appears:

![Question dialog]

Now click on:

- **Yes** to delete the view,
- **No** to cancel deletion.

### 3. DISPLAY SETTINGS

#### Access

The display settings are displayed automatically when a view is created.

There are several ways to access a view's Display Settings:

- Go to **General settings > Click on Predefined views > Choose the view > Display settings,**
- Go to **Display > Click on Display Settings,**
Click on the button in the view header.

In all cases, a window appears.

Now modify the settings and click on the **Validate** button.

The window has six tabs:

- **Events List tab**,
- **Planner tab**,  
- **Events tab**,  
- **Workloads tab**,  
- **Printing tab**,  
- **Synchronization tab**.

### Events List tab

**Display row numbers**  
Check this box to display the event row numbers.

**Display totals**  
Check this box to display the total values of the numeric, control column and operation headings.

**Icon size**  
Choose the size of icons, from 16 to 64 pixels.

**Labels**  
You can choose one or more headings to view for events or event attributes.

Use this button 🖋️ to open the following window:

![Editeur des propriétés window](image)

To add a label, select the label in the left-hand part, then drag it to the right-hand part using the arrows.
You can also sort appearance of data in the progress bar using the sorting arrows.

Font

Right-click on the right-hand button to open the font definition window:

You can choose:

- a font,
- a style (bold, italics, etc.),
- a character size.

Icon Dimensions

You can choose one or more dimensions to show the event icons.

Use this button 🖌️ to open the following window:
Simply drag them from left to right using the arrows:

Color Dimensions

Each event’s background color can be:

- one color if a single dimension is chosen to show the color,
- multi-colored if several dimensions are chosen to show the color.

If several dimensions are chosen, the colors will only be visible in Details mode. In Table mode, only the color of the first dimension appears.

Use this button 🆕 to open the following window:
Filter of authorized 'Dimensions'

Select the dimension filters that will be available for use in this view.

Planner tab

This tab is for configuration of the planner grid.
Daily calendar

Choose one of the [daily calendars](#) to be seen as the background color for the planner grid.

This calendar is not necessarily from the view’s resources.
Layout and display

Hourly calendar

Choose one of the hourly calendars to be seen as the background color for the planner grid.

This calendar is not necessarily from the view's resources.

Column width

Enter a numeric value corresponding to the width in pixels of each column in the planner grid.

Font

Right-click on the right-hand button to open the font definition window:

You can choose:

- a font,
- a style (bold, italics, etc.),
- a character size.

Set to the current date

Check this box to set the planner to the current date, the first time the view is started.

Scale

You must specify the view's time scale.
Scroll
You can define the view scrolling method when using scroll arrows.
The possibilities are:

- Continuous: the planner scrolls like a continuous, endless document,
- Day: the planner can only be viewed day by day The view always represents a single entire day,
- Week: same as Day. The view always represents a single entire week,
- Month: same as Day. The view always represents a single entire month,
- Year: same as Day. The view represents a single entire year,

Display hourly calendars
Check this box to display the resources’ hourly calendars.

Non working days
Check this box to display days whose period type is non working.

Night hours
Check this box to display night hours.
These night hours are determined by the start and end times explained below.

Vertical grid
Check this box to show the vertical grid on the planner.

Display weeks
Check this box to display the week numbers next to the date on the planner.
This option is only necessary when the time scale is:

- Day,
- 1/2 Day,
- 1/3 Day,
- or 1/4 Day.

Start time
Each day can be limited by a start time and an end time.
These times are the same for every day in the view, regardless of the time scale.

Specify the start time for the days.

This start time is only necessary when the **night hours** option is disabled.

This start time is not linked to the hourly calendars.

**End time**

Each day can be limited by a start time and an end time.

These times are the same for every day in the view, regardless of the time scale.

Specify the end time for the days.

This end time is only necessary when the **night hours** option is disabled.

This end time is not linked to the hourly calendars.

**Period**

This is where you should specify the associated [Time Period](#) which will be used to limit display of the planner.

If you choose a **customized period**, it is possible to create a period linked solely to this display of the planner. (See [Customized](#))

**Background color**

You can choose the view's background color.

This color is for days and times where the type of period does not have a color.

This choice also applies to the resources background color if no such color is specified.

**Display links**

Check this box to display the links between events in the view.

Most of these properties are also available in the display menu or by **Right-clicking on the planner header**.

**Events tab**

This tab is for configuration of the time bars.
Automatic line return
Check this box to force a line return in time bar texts depending on their widths.

Fixed height
Check this box to set the same height as the row for all planner events.
Font

Right-click on the right-hand button to open the font definition window:

You can choose:

- a font,
- a style (bold, italics, etc.),
- a character size.

Time bars label

You can choose one or more headings to view for events or event attributes.

Use this button 🖋️ to open the following window:
To add a label, select the label in the left-hand part, then drag it to the right-hand part using the arrows.

You can also sort appearance of data in the progress bar using the sorting arrows.

**Display according to calendar**

Check this box to cut the event time bars:

- according to the hourly resource calendars if the time scale is less than one day,
- according to the daily resource calendars if the time scale is more than one day.

The events will then be displayed cut if they overlap non working periods.

**On one row**

Check this box to put

- all the labels on the same row.
- Otherwise there will be one label on each row.
Separator
If display of the labels is on one row, it is necessary to define one or more characters to separate the labels.

Display titles
Check this box to display the label names visible on the time bar.

Alignment
You can choose the position of the labels in relation to the time bar.
The possible choices are as follows:

- Left,
- Right,
- Center,
- External. In this last case, the labels are visible outside the time bar, to the right.

Border color dimension
This list enables you to choose the dimension whose resources color will be used as the time bar border color.

Use this button to edit the chosen dimension and modify its default color.

Border thickness
You can specify the thickness of this colored border by modifying the numeric value of this thickness.

Background color dimensions
The time bar background color can be:
■ none,
■ one color if a single dimension is chosen to show the color,
■ Or multi-colored if several dimensions are chosen to show the color.

Use this button to open the following window:

In this window you can simply **drag them from left to right** using the arrows:

You can also sort the order of appearance of dimension colors in the time bar using the sorting arrows.

**Display the progress bar**

You must check this box to display the state of progress on the time bar.

**Progress color**

You can choose the progress bar color by **left-clicking on the color**.

The color map then opens.
Bar position
This choice list enables you to define the position of the progress bar on the time bar.
This position can be:

- High,
- Center,
- Low.

Urgent color
The urgent color indicates the event’s status is urgent.
It is visible

- as the progress bar color,
- or the border color.

You can choose the urgent color by left-clicking on the color.
The color map then opens.

This is only necessary if achievement is manual. In automatic achievement mode the event cannot be urgent.

Always visible
Check this box to make icons visible even if the time bar is narrower than the icon.

Aligning the icon
You can display one or more icons on the time bar.
These icons can be aligned:

- to the left,
- or the right of the time bar.

Icon Dimensions
You can choose one or more dimensions to show the event icons.

Use this button 🧾 to open the following window:
Simply **drag them from left to right** using the arrows:

You can also sort the order of appearance of dimension icons in the time bar using the sorting rows.

**Icon size**

Choose the size of icons. from 16 to 64 pixels.

**Tooltips like time bars**

You can display different information in the time bars and the **tooltips**.

If you **uncheck** this box, the information displayed in the tooltip can be different from the information shown in the time bar.

**Tooltip labels**

If the previous box is not checked, you can modify the tooltip labels.

Use this button ✒ to open the following window:
To add a label, select the label in the left-hand part, then drag it to the right-hand part using the arrows.

You can also sort appearance of data in the time bar using the sorting arrows.

**Allowed Event filters**

The list of filters available in the Schedule view can be shortened by choosing from the existing filters.
Workloads tab

Display total
Check this box to display an additional workload that computes the total of visible workloads.

Display workloads
Check this box to display the workloads selected below in the Schedule view.
Workload

Choose the workload(s) to display in the Gantt events view.

Printing tab

Use this tab to define the view printing settings. (See Printing a view)
Adjustment
To adjust printing to the page size.

The possible adjustments are:

■ None,
■ To the page,
■ To the width,
■ To the height.

The row height when printing on several pages is adjusted to the maximum height encountered during the entire printed period.

Footer
To define the printing footer:

The following buttons enable you to define automatic information:

■ : Page number,
■ : Number of pages,
■ : Print date,
■ : Print time,
■ : Planner name,
■ : View name,
■ : Name of user,
■ : Name of permission group.
You can also type in a specific text directly in the relevant zone.

**Header**

To define the printing header:

![Image]

The following buttons enable you to define information automatically:

- ![Page number]: Page number,
- ![Number of pages]: Number of pages,
- ![Print date]: Print date,
- ![Print time]: Print time,
- ![Planner name]: Planner name,
- ![View name]: View name,
- ![Name of user]: Name of user,
- ![Name of permission group]: Name of permission group.

You can also type in a specific text directly in the relevant zone.

**Page layout**

The following window appears, where you can define the default **page layout** settings for the selected view:
You must specify the page layout characteristics in this window.

You can save this page layout definition in a favorite display.

You must then click on **OK** to validate the page layout.

**Show logo**

Check this box to show the logo top left in the printing output.

**Select logo**

The logo is an image file that can be displayed in the printing output.

This image is unique for the entire planner.

Click on [...] to display the following window:
You must then look through the directories to select an image file, and click on the Open button.
Synchronization of a view consists in defining the characteristics that will be dependent on the other views.

The possibilities are as follows:

**Events filters**
You can synchronize the view’s events filter with the events filters of the other views.
Resource filter

You can synchronize the view’s resources filter with the filters of the other views.
Chapter XIII. Kanban Events View

1. DEFINITION

A Kanban Events View enables you to view a list of events from one or more resources using the Kanban method.

This is a highly visual representation of events, and makes it easy to manipulate events according to a specific flow.

2. DISPLAY SETTINGS

Access

The display settings are displayed automatically when a view is created.

There are several ways to access a view’s Display Settings:

- Go to General settings > Click on Predefined views > Choose the view > Display settings, or;
Go to **Display > Click on Display Settings**, or;

- Click on the button in the view header.

In all cases, a window appears.
Now modify the settings and click on the Validate button.

The window has three tabs:

- **Events List tab**,
- **Printing tab**,
- **Synchronization tab**.

### Events List tab

**Period**

You can display events over a period:

- Continuous,
- Day,
- Week,
- Month,
- Year.

Events will then appear according to the chosen period.

**Dispatch according to**

It is possible to break down the columns according to a dimension to have a representation corresponding to the Kanban method.

**Dispatch according to the same dimension as the events view dimension**

If the columns are broken down according to the same dimension, dragging-dropping an event from one column to another will modify the event's resource.

*Example: If the breakdown dimension concerns event statuses, an event’s status will change to validated by dragging-dropping the event from the “Requested” column to “Validated”.*

**Dispatch according to a different dimension from the events view dimension**

If the breakdown uses a different dimension from the one used to create the events view, dragging-dropping an event from one column to another will create a new event with the resource from the breakdown dimension.

*Example: If the breakdown dimension concerns event statuses, an event with “Validated” status will be created just by dragging-dropping the event from the “Requested” column to “Validated”. The event that had “Requested” status will disappear from the events view but will still exist.*

**Resource in column**

Here you choose the resources that will be distributed to the column.
Number of rows
Choose the number of rows to use to distribute the resources chosen above.

Auto Format text
Check this box to display the names of VISUAL PLANNING attributes and entities in the view.

Display headers
Check this box to display the names of VISUAL PLANNING entities and attributes.

Example: Event-Start day: 24/11/2015 or Start day: 24/11/2015

Display short names
Check this box to display the names of dimensions to which the headings to display belong, or the names of the VISUAL PLANNING entities.

Example: Start Day: 24/11/2015 or Name: MARTIN

Unrestricted HTML text
This option is only available if the Auto Format Text box is not checked.

Right-clicking brings up an HTML editor.
This makes it possible to create your own visuals for events in the view:

- By entering formatted or unformatted text,
- By inserting images, tables and event attributes.

**Icon size**

Choose the size of icons. from 16 to 64 pixels.

**Labels**

You can choose one or more headings to view for events or event attributes.

Use this button to open the following window:

To add a label, select the label in the left-hand part, then drag it to the right-hand part using the arrows.

You can also sort appearance of data in the time bar using the sorting arrows.

**Font**

Right-click on the right-hand button to open the font definition window:
You can choose:

- a font,
- a style (bold, italics, etc.),
- a character size.

**Icon Dimensions**

You can choose one or more dimensions to show the event icons.

Use this button 🗯️ to open the following window:

Simply *drag them from left to right* using the arrows:
Color Dimensions

Each event’s background color can be:

- one color if a single dimension is chosen to show the color,
- multi-colored if several dimensions are chosen to show the color.

If several dimensions are chosen, the colors will only be visible in Details mode.
In Table mode, only the color of the first dimension appears.

Use this button 📐 to open the following window:

Allowed Event filters

The list of filters available in the Kanban view can be shortened by choosing from the existing filters.

Filter of authorized 'Dimensions'

Select the dimension filters that will be available for use in this view.

Printing tab

Printing of an event view functions in a similar way to the WYSIWYG concept.
Use this tab to define the view printing settings. (See Printing a view)

**Adjustment**

To adjust printing to the page size.

The possible adjustments are:

- None,
- To the page,
- To the width,
- To the height.

The row height when printing on several pages is adjusted to the maximum height encountered during the entire printed period.

**Footer**

To define the printing footer:
The following buttons enable you to define automatic information:

- ☐: Page number,
- ☒: Number of pages,
- ☐: Print date,
- ☐: Print time,
- ☐: Planner name,
- ☐: View name,
- ☐: Name of user,
- ☐: Name of permission group.

You can also type in a specific text directly in the relevant zone.

**Header**

To define the printing header:

The following buttons enable you to define information automatically:

- ☐: Page number,
- Number of pages,
- Print date,
- Print time,
- Planner name,
- View name,
- Name of user,
- Name of permission group.

You can also type in a specific text directly in the relevant zone.

**Page layout**

The following window appears, where you can define the default page layout settings for the selected view:

You must specify the page layout characteristics in this window.

You can save this page layout definition in a favorite display.
You must then click on **OK** to validate the page layout.

**Show logo**

Check this box to show the logo top left in the printing output.

**Select logo**

The logo is an image file that can be displayed in the printing output. This image is unique for the entire planner.

Click on [...] to display the following window:

You must then look through the directories to select an image file, and click on the **Open** button.
Synchronization of a view consists in defining the characteristics that will be dependent on the other views.

The possibilities are as follows:

**Events filters**

You can synchronize the view’s events filter with the events filters of the other views.

**Resource filter**

You can synchronize the view’s resources filter with the filters of the other views.
Chapter XIV. Events Map view

1. DEFINITION

An Events Map view shows on a map the different events displayed in the right-hand part of the view.

2. CONFIGURATION

Creating a view

To create a view, you must go either to General Settings, or to the Display menu.

The General settings are only accessible for the planner administrator.

There are several entry points:

- Either in General Settings, right-click on a dimension > Create View > Choose the type of view,
- Or in General Settings, right-click on Predefined views > Create View > Choose the type of view,
- Or in the Display menu > Predefined views block > Create View > Choose the type of view.
Specify the subsequent characteristics, then click on the Validate button to create the view.

**Dimension**
Select the dimension that will guide the view.

**Name**
Give the view a name. This is mandatory.

**Description**
Give the view a description. The description is optional.

**Modifying a view**
To modify a view, simply change one or more of its display settings.
Then you must save these modifications. There are several entry points:

**Situation 1: Predefined views block**
This menu is accessible for all users who have the right to modify favorite displays.

Go to the Display menu > Predefined views block > Choose the view to modify.
You can then modify the view’s name and description.
Now click on:
OK to save the modifications,
Or Cancel to cancel the modifications.

General Settings
The General settings are only accessible for the planner administrator.

Go to the General Settings menu > Predefined views > Select the view. You can then modify the view’s name and description.

Now click on:

Validate to save the modifications,
Or Redo to cancel the modifications.

Deleting a view
Deleting a predefined view is an important configuration task and should not be performed without careful consideration.

Situation 1: Predefined views block
This menu is accessible for all users who have the right to modify favorite displays.

The view must be selected before it is deleted.

Go to the Display menu > Predefined views block > Choose the view to delete. The following message appears:

Now click on:

Yes to delete the view,
No to cancel deletion.

General Settings
The General settings are only accessible for the planner administrator.
Go to the General Settings menu > Predefined views > Choose the view to delete.

The following message appears:

Now click on:

- Yes to delete the view,
- No to cancel deletion.

### 3. DISPLAY SETTINGS

**Access**

The display settings are displayed automatically when a view is created.

There are several ways to access a view’s Display Settings:

- Go to General settings > Click on Predefined views > Choose the view > Display settings
Go to **Display > Click on Display Settings**

- Click on the button 📊 in the view header.

In all cases, a window appears.

```
<table>
<thead>
<tr>
<th>Carte RH</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Carte</strong></td>
</tr>
<tr>
<td><strong>Spécifiques</strong></td>
</tr>
<tr>
<td>Dimension trajet : Ressources humaines</td>
</tr>
<tr>
<td>Géolocalisation : Activités-GPS</td>
</tr>
<tr>
<td>Information html : $(ressources,humaines,-,franc},,$(ressources,humaines,-,nom)</td>
</tr>
<tr>
<td>Afficher le trajet :</td>
</tr>
</tbody>
</table>
```

Now modify the settings and click on the **Validate** button.

The window only has one tab: **Map tab**.

**Map tab**

**Routing dimension**

Choose the dimension that will be used for sorting and to group the routings according to the resource of this dimension.

**Geolocation**

Choose the heading to use for computing geolocation.

**HTML information**

Use this box to determine how information about events are displayed in the right-hand part of the view.

Right-clicking brings up an HTML editor.
This enables you to create your own visuals for events in the view:

- By entering formatted or unformatted text,
- By inserting images, tables and event attributes.

**Display the routing**

Check this box to display the routing between events.

### 4. USE

**Layout of an Events Map view**

The Events Map view is laid out in the Main window like the other views.

**Filtering displayed events**

To limit the number of events displayed, go to the Filters menu > 'Dimension' Filters block and modify the event display time.

**Printing an Events Map view**

Like the other views, you can print the Events Map view.

See [Printing](#)
Favorite display

Like the other views, an Events view can be saved in a favorite display.
Chapter XV. Events Report View

1. DEFINITION

The Events Report view shows you an Events Report in the form of a table or graph enabling you to view and analyze the data contained in the planner.

2. CONFIGURATION

Functional prerequisite

For an Events report view to exist, an events report must first be created.

Creating a view

To create a view, you must go either to General Settings, or to the Display menu.

The General settings are only accessible for the planner administrator.

There are several entry points:

- Either in General Settings, right-click on a dimension > Create View > Choose the type of view,
- Or in General Settings, right-click on Predefined views > Create View > Choose the type of view,
- Or in the Display menu > Predefined views block > Create View > Choose the type of view.
Specify the subsequent characteristics, then click on the Validate button to create the view.

**Dimension**
Select the dimension that will guide the view.

**Name**
Give the view a name. This is mandatory.

**Description**
Give the view a description. The description is optional.

**Modifying a view**
To modify a view, simply change one or more of its display settings. Then you must save these modifications. There are several entry points:

**Situation 1: Predefined views block**
This menu is accessible for all users who have the right to modify favorite displays.

Go to the Display menu > Predefined views block > Choose the view to modify.
You can then modify the view’s name and description.
Now click on:
■ **OK** to save the modifications,
■ Or **Cancel** to cancel the modifications.

**General Settings**
The General settings are only accessible for the planner administrator.

Go to the **General Settings menu > Predefined views > Select the view**. You can then modify the view’s name and description.

Now click on:
■ **Validate** to save the modifications,
■ Or **Redo** to cancel the modifications.

**Deleting a view**

Deleting a predefined view is an important configuration task and should not be performed without careful consideration.

**Situation 1: Predefined views block**

This menu is accessible for all users who have the right to modify favorite displays.

The view must be selected before it is deleted.

Go to the **Display menu > Predefined views block > Choose the view to delete**.

The following message appears:

```
Question

Vous voulez supprimer la vue prédéfinie ? 'Absences'

Attention ! Cette vue ne sera plus visible dans les favoris d'affichage qui l'utilisent.

Oui  Non
```

Now click on:
■ **Yes** to delete the view,
■ **No** to cancel deletion.

**General Settings**
The General settings are only accessible for the planner administrator.
Go to the General Settings menu > Predefined views > Choose the view to delete.

The following message appears:

Now click on:

- Yes to delete the view,
- No to cancel deletion.

3. DISPLAY SETTINGS

Access

The display settings are displayed automatically when a view is created.

There are several ways to access a view’s Display Settings:

- Go to General settings > Click on Predefined views > Choose the view > Display settings, or;
Go to **Display > Click on Display Settings**, or;
- Click on the button in the view header.

In all cases, a window appears.

![Window for display settings]

Now modify the settings and click on the **Validate** button.

The window has two tabs:
- **Events Report tab**, 
- **Printing tab**.

**Events Report tab**

**Abscissa - Rotation of labels**

This option is not available in Table mode or Pie Charts mode.
Check this box to display the labels at a 45° angle.

**Abscissa - Font**

This option is not available in Table mode or Pie Charts mode.

Use this field to modify the abscissa font.

**Click on the [...] button** to open the font definition window:

You can choose:
- a font,
- a style (bold, italics, etc.),
- a character size.

**Abscissa - Title**

This option is not available in Table mode or Pie Charts mode.

Use this field to specify a title for the abscissa axis.
Ordinate - Font

This option is not available in Table mode or Pie Charts mode.

Use this field to modify the ordinate font. (See above)

Ordinate - Title

This option is not available in Table mode or Pie Charts mode.

Use this field to specify a title for the ordinate axis.

Allowed Event filters

The list of filters available in the Events Report view can be shortened by choosing from the existing filters.

Automatic computation

Check this box to view in real time the impact the modifications of the planner have on the events report. If this box is not checked, refreshing of the view is determined by VISUAL PLANNING’s automatic refreshing.

This functionality can have a significant impact on the application’s performance, depending on the events report it is using.

Events Report

Choose the events report to view in this view.

The report must have been created in advance.

If this is not the case, you can create a new one using the following button: 

Color map

This option is not available in Table mode.
Use this field to choose the color of each data item to compute in the graphics.

**Display Type**

Use the display type to define a table, histogram, pie chart, line or area display type as shown in the following examples:
Table display: click on a row to open the editor showing the events taken into account in the computation.

Display values

This option is not available in Table mode.

Check this box to display the computation values on or at the top of the bars.

Value font

This option is not available in Table mode.
Use this field to modify the value font for the computed data. (See above)

**Caption font**

This option is not available in Table mode.

Use this field to modify the caption font. (See above)

**Number of columns**

This option can only be modified in Pie Chat mode.

It defines the number of pie charts that will be shown on the same row. Once the selected number has been reached, other graphs will be displayed under.

**Title**

This option is not available in Table mode.

Use this field to type in a title for the events report.

**Title font**

This option is not available in Table mode.

Use this field to modify the events report title font. (See above)
Printing tab

Use this tab to define the view printing settings. (See Printing a view)

Adjustment

To adjust printing to the page size.

The possible adjustments are:

- None,
- To the page,
- To the width,
- To the height.

The row height when printing on several pages is adjusted to the maximum height encountered during the entire printed period.

Only Table mode can be adjusted.
Footer

To define the printing footer:

The following buttons enable you to define automatic information:

- Page number,
- Number of pages,
- Print date,
- Print time,
- Planner name,
- View name,
- Name of user,
- Name of permission group.

You can also type in a specific text directly in the relevant zone.

Header

To define the printing footer:

The following buttons enable you to define automatic information:
Page layout

The following window appears, where you can define the default page layout settings for the selected view:

You must specify the page layout characteristics in this window.
You can save this page layout definition in a favorite display.

You must then click on OK to validate the page layout.

Show logo

Check this box to show the logo top left in the printing output.

Select logo

The logo is an image file that can be displayed in the printing output.

This image is unique for the entire schedule.

Click on [...] to display the following window:

You must then look through the directories to select an image file, and click on the Open button.

4. USE

Layout of an Events Report view

The Events Report view is laid out in the Main window like the other views.

Display type of an Events Report view

When an Events Report view is selected, its default display type is Table.

You can then modify the Events Report display type using 2 entry points.
Display tab \rightarrow Events Reports menu

To re-edit the Events Report, click on this button \( \text{edit} \).

To change the Events Report, choose from the list shown.

To change the **Display type**, choose from the options shown: Table, Histogram, Pie Charts, Lines or Areas.

![Display options](image)

**Pop-up menu**

To re-edit the Events Report, *right-click on the view header > Modify*.

To change the events report, *right-click on the view header > Events report > Choose* from the list shown in the pop-up menu.

To change the display type, *right-click on the view header > Display type > Choose* from the options shown in the pop-up menu.

**Sorting the report rows**

Unlike the other views which have a table mode, it is not possible to sort the rows in an Events Report.

They must sorted in advance when configuring the events report in the **Data analysis** section.

**Printing an Events Report view**

Like the other views, you can print the Events Report view.

See [Printing](#).
Favorite display

Like the other views, an Events report view can be saved in a favorite display.
Chapter XVI. Favorite display

1. DEFINITION

A favorite display is a “photograph” of the main VISUAL PLANNING window. It is usually linked to a scenario for using the tool. This is one of the most important functionalities for end users of VISUAL PLANNING. Thanks to favorite displays, users can quickly find their favorite dashboard. A favorite display consists mainly of views. These are duplicates of existing views. In particular, a favorite display memorizes:

- the view(s) used, their position(s) and characteristics,
- the filters applied.

To optimize communication between employees using the tool, it is recommended to make available to users a library of public favorite displays, each corresponding to a planning need.

You can also allow users to create their own private favorite displays.

2. USE

The aim is to use the "library" of elements made available to create the desired display.

Creating a favorite display

To create a favorite display, go to Display menu > Favorite displays >

The following window appears:
Specify the characteristics below.

**Name**

Give this display a name.

**Category**

Attach this display to a Category if necessary.

If the category exists, select it. Otherwise, type in the name of the new category.

This option is only available if the favorite display is public.

**Private**

Check this box to keep the favorite display private.

If it is not checked, the display is public and will be visible to everyone, unless display visibility has been restricted in the permissions.

A public favorite display cannot be made private.
**Start-up display**

Check this box to directly start this favorite display when the planner is opened.

If this box is checked for several favorite displays, the first one in the list will be started, unless display visibility has been restricted in the permissions.

**Description**

Give a Description. The description is optional.

Finally you must confirm creation of the display by clicking on the **OK** button.

To create a new favorite display, you can also use the following keyboard short-cut: **Ctrl + Shift + S**

**Saving an existing favorite display**

To save an existing favorite display, go to the **Display menu > Favorite displays >**

To save a new favorite display you can also use the following keyboard short-cut: **Ctrl + S**

**Selecting a favorite display**

To select a favorites display go to the **Display menu > Favorite displays > click on the arrow to select a favorite display > select the name of the favorite display.**
You can also select a favorite display by clicking on this button.

Deleting a favorite display

To delete a favorite display, go to Display menu > Favorite displays > button.

A confirmation window opens:
Click on **Yes** to definitively delete the favorite display.

*Deletion of a favorite display is irreversible.*
Chapter XVII. Resources Editor

1. DEFINITION

Use a Resources Editor to create and modify resources using an appropriate customized format.

This functionality is used to replace the default editor so as to organize visible information in this window.

2. CONFIGURATION

Only users identified as “administrators” have access to the configuration.

These administrators can be:

- The general administrator,
- possibly the planner’s administrators.

Default Template

There is one default resources editor for each dimension.

This template is used:

- if no other template exists,
- or if none of the templates match the selected resource,
- or if the resource can be edited with several templates.

To view this template, go to the pane for General settings > Settings > Input editors > Resources editors > ‘Dimension’ - (Default)

The corresponding pane is then displayed:
The only possible configuration for this template is the **Always accessible** checkbox. Uncheck this box to conceal the existence of this template whenever a template is compatible with resource selection.

It is recommended not to uncheck this box when testing the application.

---

### Classifying headings in the default editor

There are two ways to classify headings in the default editor.

**By the order of headings defined in the dimension**

- For a Resources view, go to the view’s Display Settings and uncheck the **Sort the default editor** checkbox,
- For a Schedule view, go to the view’s Display Settings > select the Resource Rows tab and uncheck the **Sort the default editor** checkbox,
By the order of headings defined in the display settings

- For a Resources view, go to the view’s Display Settings and check the **Sort the default editor** checkbox,
- For a Schedule view, go to the view’s Display Settings > select the Resource Rows tab and check the **Sort the default editor** checkbox,

Headings not displayed in the **Headings** field of the **Resource Rows** tab will follow the order defined in the dimension.

Creating a Resource Editor

You can access the Input Editors menu using either the **General settings > Input editors** pane, or via the **Settings > Configuration block > Input editors menu**.
Once you are in the window, right-click on **Resource Editors > Create Editor > Choose the required dimension**:

The corresponding pane is enabled:

![Image of Editeur de ressources]

Specify the characteristics of the template, and click on the **Validate** button to validate creation. These characteristics are:

**Name**
The Name field is required. It gives the template a name.

**Description**
The Description field is optional. It gives the template a description.

**History**
This represents the creation date and time and the most recent change to the template, together with the login of the user who made the change.

This characteristic cannot be edited.

**Activated**
This box determines whether the template is active.
Uncheck the box to make the resource editor temporarily unavailable.

**Dimension filter**

Choose the filter that defines the resources to which the template applies.

See [Resource Filters](#)

**Editor**

To access the editor and configure its settings, click on this button 📒:

The following window appears:

Now build the editor using different objects to fill in or simply see the resource’s characteristics.

The object types are:
Resource headings

Select the headings.

- If the dimension has a Resource type of heading, its headings can also be displayed in the Resource Editor. However you will not be able to modify these headings.
- **Special case of the image:** An Image type attachment heading will adapt to the size of the editor component.

Text input

You can insert text blocks positioned in the editor. To modify the text, double-click in the created text zone.
The following window appears:

Format the text.

**Inserting attributes**

You can insert schedule attributes into the text. However these attributes cannot be modified. To do this, go to **Insert > Attributes > Choose the attribute to add**.

These characteristics cannot be modified when using the editor.

**Inserting an image**

Images can be inserted in the text by selecting a file in the **Image URL** property.
This image is directly converted in BASE64 in order to be saved in the planner .vps file.

**Events list**

You can insert an [Events view](#) enabling you to view the events of the selected resource.

**Delete**

To delete an object, select it and click on [Delete](#).

**Grid alignment**

The editor interface is divided into a grid defined by points.
When you select the **Grid alignment** button, the interface components move between these points. If you do not select this button, they move pixel by pixel.

**Default title**

![Default title button](image)

After renaming a component, you can go back and give it its default name again by selecting it and clicking on **Default title**.

**Shift to**

![Shift to button](image)

---

This function is only active if the editor has at least 2 tabs.

---

To move a component from one tab to another, select it and click on the **Shift to** button.

**Tab Management**

Editors enable you to organize fields on several tabs within a resource’s editing window.

To add a new tab click on this button ![+] . You can rename the tab by clicking on this button ![pencil]. This displays the list of tabs in the editor:
Browse from one tab to another to add fields that will constitute the editor.

The picture below shows a preview of the tabs.

To delete a tab, select it in the pull-down list and click on the deletion button.

**Preview**

You can preview the configured editing window.

**Pop-up menu**

You can also add components using a pop-up menu (right-click). The mouse cursor position defines the top left corner of the added component.
When choosing components to add in the input editor, you can select several elements in one operation by clicking on Select headings.

The following window opens:

![Select headings window](image)

You can select the attributes you want to add from a list. By default they are all selected.

**Object alignment**

You can align a set of objects with a single click.

First select the objects to align, then align them using the following block:
Left alignment: The objects are aligned left with the event you clicked on;

Center alignment: The objects are centered with respect to the event you clicked on;

Right alignment: The objects are aligned right with the event you clicked on;

Top alignment: The objects are aligned with the top of the object you clicked on;

Middle alignment: The objects are aligned at the same height as the middle of the event that you clicked on;

Bottom alignment: The objects are aligned with the bottom of the object you clicked on;

Same size

You can make the width or height of the components the same.

Select the objects and make them the same size by right-clicking on the reference event.
Naming objects

Some objects have to be renamed to correspond to business terminology.

**Double-click on the object to rename** and type the new name in the window that appears.

**Undo / Redo**

When adding a field, you can undo or redo the eliminated data using the corresponding arrows.

**Example of a Resource Editor**

| Configuration | Preview of the result |
Modifying a Resource Editor

To modify a resource editor, go to **General settings > Input editors > Resource editors > Select editor to modify**. The corresponding window is enabled.

Modify the characteristics, then click on the **Validate** button to save the resources editor.

See **Creating a Resource Editor**

Deleting a Resource Editor

To delete a resource editor, go to **General settings > Input editors > Resource editors > Right-click on the editor to delete > Delete**.

The following screen appears:

![Confirmation screen for deleting a resource editor](image)

Click on **Yes** to delete the editor.
You cannot delete a default resource editor.

### Duplicating a Resource Editor

To duplicate a resource editor, go to **General settings > Input editors > Resource editors > Right-click on the editor to duplicate > Duplicate.**

Carry out the necessary modifications and **Validate** to save them.

You cannot duplicate a default resource editor.

### 3. USE

A Resource Editor is very easy to use.

#### Double-click on a resource

If a resource corresponds to a resource filter defined in an editor, and only corresponds to one filter, this resource editor will open when you double-click on this resource. Otherwise, the default editor will open.

If the resource corresponds to two or more filters defined in the editors, the default editor will open.

#### Right-click on a resource

When you **Right-click > Modify** a resource or selection of resources, the **pop-up menu** enables you to:

- Open the corresponding editor if a single template matches it;
- Choose the template if there are several matching templates.

#### Heading tooltips

If a description has been entered in one of the headings making up the editor, it will be displayed in the tooltip when the mouse is positioned on the heading title.
Printing

You can print information from one or more resources using a resource editor template. Simply select the required resource(s) and right-click > Print > Preview or PDF depending on the requirement, and the following window opens.

At the bottom of the window you choose the editor you require in the Print according to editor field.
Chapter XVIII. Event Editor

1. DEFINITION

Use an Event Editor to create and modify events using an appropriate customized format. This functionality is used to replace the default editor so as to organize visible information in this window.

2. CONFIGURATION

Only users identified as “administrators” have access to the configuration. These administrators can be:

- the general administrator,
- possibly the schedule’s administrators.

Default Template

There is a default event editor template. This template is used:

- if no other template exists,
- or none of the templates match the selected event,
- or if the event can be edited with several templates.

To view this template, go to the pane for **General settings > Settings > Input editors > Event editors > (Default)**

The corresponding pane is then displayed:
The only possible configuration for this template is the *Always accessible* checkbox. Uncheck this box to conceal the existence of this template whenever a template is compatible with event selection.

It is recommended not to uncheck this box when testing the application.

Creating an event editor

You can access the Input Editors menu using either the *General settings > Input editors* pane, or via the *Settings > Configuration block > Input editors menu*.

Once in the window, right-click on *Event Editors > Create Event Editor*:

The corresponding pane opens:

Now specify the characteristics of the template, and click on the *Validate* button to validate creation. These characteristics are:

**Name**

The Name field is required. It gives the template a name.

**Description**

The Description field is optional. It gives the template a description.
History

This represents the creation date and time and the most recent change to the template, together with the login of the user who made the change.

This characteristic cannot be edited.

Activated

This box determines whether the template is active.

Uncheck the box to make the resource editor temporarily unavailable.

Events filter

Choose the filter that defines the events to which the template applies.

See [Events filter](#)

Editor

To access the editor and configure its settings, click on this button 🆙:

The following window appears:

![Editor Window](image)

Now build the editor using different objects to fill in or simply see the event’s characteristics.

The object types are:
Event attributes

Select the attributes for an event.

These can be:
■ Start date,
■ End date,
■ Workload in hours,
■ …
Event resource headings

Select the headings.

- These characteristics cannot be modified when using the editor. Only the resource itself can be modified, e.g.: (Dimension 1)

- Special case of the image: An Image type attachment heading will adapt to the size of the editor component.

Event form headings

Select the form headings.

- If the entered form does not match the edited event form, the corresponding fields will be empty.
- **Special case of the image**: An Image type attachment heading will adapt to the size of the editor component.

## Valuation items

![Valuation items](image)

Select the valuations.

- If the entered valuation item is not linked to the edited event, the corresponding fields will be empty.
- You can choose total valuation (which corresponds to the total valuations in the same unit).

## Text input

![Text input](image)

You can insert text blocks positioned in the editor. To modify the text, double-click in the created text zone.

The following window appears:
Format the text.

**Inserting attributes**

You can insert schedule attributes into the text. However these attributes cannot be modified. To do this, go to **Insert > Attributes > Choose the attribute to add.**

These characteristics cannot be modified when using the editor.

**Inserting an image**

Images can be inserted in the text by selecting a file in the **Image URL** property.

This image is directly converted in BASE64 in order to be saved in the planner .vps file.
Child Events list

You can insert an Events view enabling you to view the child events of the selected event.

This only enables you to view child events of the level immediately below.

Delete

To delete an object, select it and click on Delete.

Grid alignment

The editor interface is divided into a grid defined by points.

When you select the Grid alignment button, the interface components move between these points. If you do not select this button, they move pixel by pixel.
After renaming a component, you can go back and give it its default name again by selecting it and clicking on **Default title**.

**Shift to**

This function is only active if the editor has at least 2 tabs.

To move a component from one tab to another, select it and click on the **Shift to** button.

**Tab Management**

Editors enable you to organize fields on several tabs within a resource’s editing window.

To add a new tab click on this button . You can rename the tab by clicking on this button

This displays the list of tabs in the editor:

Browse from one tab to another to add fields that will constitute the editor.
The picture below shows a preview of the tabs.

![Tabs Preview](image)

To delete a tab, select it in the pull-down list and click on the deletion button.

**Preview**

![Preview](image)

You can preview the configured editing window.

**Pop-up menu**

You can also add components using a pop-up menu (right-click). The mouse cursor position defines the top left corner of the added component.

![Pop-up Menu](image)

When choosing components to add in the input editor, you can select several elements in one operation by clicking on **Select attributes** or **Select headings**.

The following window opens:
You can select the attributes you want to add from a list. By default they are all selected.

You can select the attributes / headings you want to add from a list. By default they are all selected.

**Object alignment**

You can align a set of objects with a single click.

First select the objects to align, then align them using the following block:

- Left alignment: The objects are aligned left with the event you clicked on;
- Center alignment: The objects are centered with respect to the event you clicked on;
- Right alignment: The objects are aligned right with the event you clicked on;
Layout and display

- **Top alignment**: The objects are aligned with the top of the object you clicked on;
- **Middle alignment**: The objects are aligned at the same height as the middle of the event that you clicked on;
- **Bottom alignment**: The objects are aligned with the bottom of the object you clicked on;

**Same size**

You can make the width or height of the components the same.

Select the objects and make them the same size by right-clicking on the reference event.

**Naming objects**

Some objects have to be renamed to correspond to business terminology.

**Double-click on the object to rename** and type the new name in the window that appears.

**Undo / Redo**

When adding a field, you can undo or redo the eliminated data using the corresponding arrows.

**Event editor example**

<table>
<thead>
<tr>
<th>Configuration</th>
<th>Result</th>
</tr>
</thead>
</table>

STILOG IST, all rights reserved
Modifying an event editor

To modify an event editor, go to General settings > Input editors > Event editors > Select editor to modify. The corresponding window is enabled.

Modify the characteristics, then click on the Validate button to save the resources editor.

See Creating an event editor

Deleting an event editor

To delete an event editor, go to General settings > Input editors > Event editors > Right-click on the editor to delete > Delete.

The following screen appears:
Click on Yes to delete the editor.

You cannot delete a default event editor.

Duplicating an event editor

To duplicate an event editor, go to General settings > Input editors > Event editors > Right-click on the editor to duplicate > Duplicate.

Carry out the necessary modifications and Validate to save them.

You cannot duplicate a default events editor.

3. USE

Assigning to a creation rule

The creation rule can require an editor to open whenever an event is created.

In this creation rule you must therefore specify which editor to use when creating the event.

Opening the editor

An event editor is very easy to use.

When you Right-click > Modify an event or selection of events, the pop-up menu enables you to:

- Open the corresponding editor if a single template matches it;
- Choose the template if there are several matching templates.

Printing an editor

You can print an event using an event editor.
Right-click on the event to print > Print > Preview or PDF depending on your need. The following window opens:

At the bottom of the window you choose the editor you require in the Print according to editor field.
Chapter XIX. Tooltip

1. Definition
A tooltip or help bubble is displayed by moving the mouse over a time bar, link or other element.

2. Events tooltip
- Content: All the event's characteristics,
- One characteristic per line (no display on a single line),
- The names of the characteristics (“Titles”) are always displayed,
- The first line concerns and the event start and end dates / times,
- The heading titles are present in the form “Dimension Name - Heading Name”.

3. Link information popup
By mousing over the link, a popup is shown:

4. Data tooltip for workloads
- By passing the mouse over the heading of the workload plan, a tooltip will appear, corresponding to the description:
By passing the mouse over a cell in the workload plan, a tooltip will appear:

- **Headings tooltip**
  
  In a view you can show in a tooltip the label and description of the headings when the cursor is moved over them.

  This function is especially useful when the heading labels are too long.

- **VALUES TOOLTIP**
  
  In a view you can show in a tooltip the value of the heading when the cursor is moved over it.

  This function is especially useful when the heading labels are too long.

- **TOOLTIP FOR RESOURCE ROW HEADERS**
  
  In a view you can show in a tooltip the label and the value of the headings when the cursor is moved over the resource row header.

  This function is especially useful when the heading labels are too long.
<table>
<thead>
<tr>
<th>Nom:</th>
<th>TROSSE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prénom:</td>
<td>Alba</td>
</tr>
<tr>
<td>Adresse:</td>
<td>55 avenue des champs pierreux 92000 Nanterre</td>
</tr>
<tr>
<td>Fonction / Métier:</td>
<td>Ouvrier</td>
</tr>
</tbody>
</table>
Chapter XX. Time scale

1. DEFINITION

The time scale defines the precision of the temporal representation of the view.

This scale can be seen as a tool making it possible to:

■ zoom in (for short-term data input),
■ zoom out (for long-term visualization).

The precision may be different depending on the view that is used.

2. SCHEDULE VIEW

In Schedule View, the time scale is represented by the mesh of each schedule column:

■ Year,
■ Semester,
■ Quarter,
■ Month,
■ Week,
■ Day,
■ 1/2 Day,
■ 1/3 Day,
■ 1/4 Day,
■ Hour,
■ 1/2 hour,
■ 1/4 hour,
■ 10 minutes,
■ 5 minutes.

3. DIARY VIEW

In Diary View, the time scale can be:

■ in width:
  ▪ the day,
4. GANTT EVENTS VIEW

In Gantt Events View, the time scale is represented by the mesh of each schedule column:

- Year,
- Semester,
- Quarter,
- Month,
- Week,
- Day,
- 1/2 Day,
- 1/3 Day,
- 1/4 Day,
- Hour,
- 1/2 hour,
- 1/4 hour,
- 10 minutes,
- 5 minutes.

5. USE

Viewing the time scale

You view the time scale:

- Horizontally in Schedule View and Gantt Events View,
Example:

Day time scale in Schedule View or Gantt Events View:

![Schedule View Example](image)

- Vertically in Diary View,

Example:

Hour time scale in Diary View:

![Hour Scale Example](image)

Modifying the time scale

In Schedule or Gantt Events view

There are several ways to modify the time scale in Schedule and Gantt Events view:

- Menu **Display > Scale**,  
- **Right-click on the schedule header > Scale**,  
- Position the cursor on the schedule header, then **Ctrl + Thumbwheel**.

In Diary View

There are several ways to modify the time scale in Diary view:

- Menu **Display > Diary Block > Scale**,  
- **Right-click on the schedule header > Scale**,
■ Position the cursor on the diary left-hand column, then Ctrl + Thumbwheel.
Chapter XXI. Color map

1. DEFINITION

The color map is a tool enabling you to select a color in VISUAL PLANNING.

2. USE

There are several ways to access the color map in VISUAL PLANNING. (See Linked concepts)

For example, in the resource property window a color is viewed as shown below:

The assigned color is modified by clicking on it.

There are then several ways to choose the color.

Quick map

You can click on a resource’s color to display a default map and easily choose one of the suggested colors.

If you don’t like any of the colors, you can click on Choose a color to display other maps: Color wheel or Color map.
Color wheel
3. LINKED CONCEPTS

Use the color map to define the colors of the following items:

- resource color,
- highlighting color,
- event background color,
- event border color (outline):
  - selecting a dimension,
  - urgent,
  - achieved.
- progress bar color:
  - urgent,
  - completed.
- icon pixel color.
Chapter XXII. Highlighting

1. DEFINITION

Highlighting is the resources’ background color.

This highlighting is in Schedule view and in Resources view.

2. USE

Highlighting can be saved in a view and in the favorite displays.

By default, no highlighting is defined.

To modify resource highlighting, click on the button for display settings top right in the selected view.

In Schedule view, select the Resource rows to modify the background color.

Now choose the resource background color which can be defined:

- either by the color of the resource itself,
- or by the color of the resource linked within a resource heading (Resource heading),
- or by the color of the resource linked within a resource heading, itself linked within a resource heading (resource “dependent” on the “dependent” resource),
- or by the color of one of the control column or operation headings, defined by the colors of their thresholds if they are defined as persistent,
- or by the color of the resource referenced in one of the event value headings if it references a resource and it is defined as persistent.

Regardless of the highlighting defined, the computed headings that use thresholds keep the color of their thresholds.